summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-02-17 20:46:14 +0800
committerwangjiezhe2016-02-17 20:46:14 +0800
commitc451ad188721a0a90cf0d87a8448b2ca7aea6fa6 (patch)
tree6f42bb85c3d4252383d85f138b65e9e12c5ce8f9
parentf229eb5ca6579ae46b58cd4debf2e143d7d23fd0 (diff)
downloadaur-c451ad188721a0a90cf0d87a8448b2ca7aea6fa6.tar.gz
upgpkg: octave-financial 0.5.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--octave-financial.install8
3 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78e9946e6a56..a4763cc19f6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Feb 17 12:46:08 UTC 2016
pkgbase = octave-financial
pkgdesc = Financial manipulation, plotting functions and additional date manipulation tools.
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.5.0
+ pkgrel = 1
url = http://octave.sourceforge.net/financial/
install = octave-financial.install
arch = any
@@ -9,9 +11,9 @@ pkgbase = octave-financial
license = GPL3
depends = octave>=3.0.1
depends = octave-io>=1.0.18
- noextract = financial-0.4.0.tar.gz
- source = http://downloads.sourceforge.net/octave/financial-0.4.0.tar.gz
- md5sums = d4d8eaaf75af34c71b2c34c4e83655ae
+ noextract = financial-0.5.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/financial-0.5.0.tar.gz
+ md5sums = 62ad058e23ce34d0a81bf5e86a1219c7
pkgname = octave-financial
diff --git a/PKGBUILD b/PKGBUILD
index fcb0102f2ff9..439784a1cd95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_pack=financial
pkgname=octave-$_pack
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Financial manipulation, plotting functions and additional date manipulation tools."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -24,7 +24,11 @@ install=$pkgname.install
_archive=$_pack-$pkgver.tar.gz
source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
-md5sums=('d4d8eaaf75af34c71b2c34c4e83655ae')
+md5sums=('62ad058e23ce34d0a81bf5e86a1219c7')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
_install_dir() {
src=$1
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-financial.install b/octave-financial.install
index 52de2057a9ba..12c05ef89bfd 100644
--- a/octave-financial.install
+++ b/octave-financial.install
@@ -1,7 +1,11 @@
_pack=financial
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}