summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-23 14:27:18 -0500
committerCarlos Aznarán Laos2022-01-23 14:27:18 -0500
commita65b0841306ccaf5e77c6d40d9a384a9fa0fb618 (patch)
tree2dfd2fd5774a2a1eaba5ac8a6b2bb03520166ff5
parent169903a13c9e4ca123731145f19af3ec2425064e (diff)
downloadaur-a65b0841306ccaf5e77c6d40d9a384a9fa0fb618.tar.gz
Update upstream URL
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be8b2eb646cf..292fa893ea0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = octave-fits
- pkgdesc = The Octave-FITS package provides functions for reading, and writing FITS (Flexible Image Transport System) files. This package uses the libcfitsio library.
+ pkgdesc = The Octave-FITS package provides functions for reading, and writing FITS (Flexible Image Transport System) files. This package uses the libcfitsio library
pkgver = 1.0.7
pkgrel = 2
- url = https://octave.sourceforge.net/fits/
+ url = https://octave.sourceforge.io/fits
install = octave-fits.install
arch = any
groups = octave-forge
@@ -11,7 +11,6 @@ pkgbase = octave-fits
depends = octave>=3.0.0
noextract = fits-1.0.7.tar.gz
source = https://downloads.sourceforge.net/octave/fits-1.0.7.tar.gz
- sha256sums = 95124173f852498cb71acc97712af104027669f60c4f972bbcd8c59b2b2f4b49
+ sha512sums = e9dc1cdab6262946564c9ae34591100d938146bb8e4631ae7fb7b2eb33aaa0246312ac274d14de23d101b8d1533d825778c9fbb31ecd68a1c78f01e2e48812ba
pkgname = octave-fits
-
diff --git a/PKGBUILD b/PKGBUILD
index f81996cc7236..5294357ebbc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
-# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -8,12 +9,12 @@
#
_pack=fits
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.0.7
pkgrel=2
-pkgdesc="The Octave-FITS package provides functions for reading, and writing FITS (Flexible Image Transport System) files. This package uses the libcfitsio library."
+pkgdesc="The Octave-FITS package provides functions for reading, and writing FITS (Flexible Image Transport System) files. This package uses the libcfitsio library"
arch=(any)
-url="https://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=3.0.0')
@@ -21,39 +22,40 @@ makedepends=('cfitsio')
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("https://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-sha256sums=('95124173f852498cb71acc97712af104027669f60c4f972bbcd8c59b2b2f4b49')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('e9dc1cdab6262946564c9ae34591100d938146bb8e4631ae7fb7b2eb33aaa0246312ac274d14de23d101b8d1533d825778c9fbb31ecd68a1c78f01e2e48812ba')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}