summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 11:13:44 +0800
committerwangjiezhe2015-10-27 11:13:44 +0800
commit58c6adcb95ffc5bb15c25c89e86d54887110b491 (patch)
tree1bd13d01e1122f77b88adf289de383517a3e9a3d
downloadaur-58c6adcb95ffc5bb15c25c89e86d54887110b491.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--octave-ga.install13
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b3ec0c9b7dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-ga
+ pkgdesc = Genetic optimization code
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = http://octave.sourceforge.net/ga/
+ install = octave-ga.install
+ arch = any
+ groups = octave-forge
+ license = GPL
+ depends = octave>=3.4.0
+ noextract = ga-0.10.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/ga-0.10.0.tar.gz
+ md5sums = ecf6582ff0f5c81d0c166f3fc9ccfc25
+
+pkgname = octave-ga
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ab935f5aad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=ga
+pkgname=octave-$_pack
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Genetic optimization code"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL')
+groups=('octave-forge')
+depends=('octave>=3.4.0')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('ecf6582ff0f5c81d0c166f3fc9ccfc25')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-ga.install b/octave-ga.install
new file mode 100644
index 000000000000..a78be6d05cea
--- /dev/null
+++ b/octave-ga.install
@@ -0,0 +1,13 @@
+_pack=ga
+
+post_install() {
+ octave-cli -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave-cli -q -f --eval "pkg rebuild -global"
+}