summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 11:15:08 +0800
committerwangjiezhe2015-10-27 11:15:08 +0800
commit195c9f006f99dc23c309d778e899cfaa443b5784 (patch)
treea995afe5b737f83547828cdfc0af680c8207510e
downloadaur-195c9f006f99dc23c309d778e899cfaa443b5784.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--octave-generate_html.install13
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0488ac551e24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = octave-generate_html
+ pkgdesc = This package provides functions for generating HTML pages that contain the help texts for a set of functions. The package is designed to be as general as possible, but also contains convenience functions for generating a set of pages for entire packages.
+ pkgver = 0.1.9
+ pkgrel = 1
+ url = http://octave.sourceforge.net/generate_html/
+ install = octave-generate_html.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ makedepends = texinfo
+ depends = octave>=3.2.0
+ noextract = generate_html-0.1.9.tar.gz
+ source = http://downloads.sourceforge.net/octave/generate_html-0.1.9.tar.gz
+ md5sums = 322974d6724e4d3062fa7b44a2ab0e9f
+
+pkgname = octave-generate_html
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc85817b5f70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=generate_html
+pkgname=octave-$_pack
+pkgver=0.1.9
+pkgrel=1
+pkgdesc="This package provides functions for generating HTML pages that contain the help texts for a set of functions. The package is designed to be as general as possible, but also contains convenience functions for generating a set of pages for entire packages."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.2.0')
+makedepends=('texinfo')
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('322974d6724e4d3062fa7b44a2ab0e9f')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-generate_html.install b/octave-generate_html.install
new file mode 100644
index 000000000000..df760d017d03
--- /dev/null
+++ b/octave-generate_html.install
@@ -0,0 +1,13 @@
+_pack=generate_html
+
+post_install() {
+ octave-cli -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave-cli -q -f --eval "pkg rebuild -global"
+}