summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-11-15 11:05:49 +0100
committerClemens Buchacher2015-11-15 11:05:49 +0100
commit682155c1190d40cbc6948f1138dce49a99337549 (patch)
treef466309a28c7ec67b49fb8bcb43683bf3619a0bd
downloadaur-682155c1190d40cbc6948f1138dce49a99337549.tar.gz
informationtheory 0.1.8
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-informationtheory.install17
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87c738c20076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-informationtheory
+ pkgdesc = Functions and routines for basic Information Theory definitions, and source coding.
+ pkgver = 0.1.8
+ pkgrel = 3
+ url = http://octave.sourceforge.net/informationtheory/
+ install = octave-informationtheory.install
+ arch = any
+ groups = octave-forge
+ license = GPL
+ depends = octave>=2.9.7
+ noextract = informationtheory-0.1.8.tar.gz
+ source = http://downloads.sourceforge.net/octave/informationtheory-0.1.8.tar.gz
+ md5sums = 8948c888555cd4377edcc3cdc8611bee
+
+pkgname = octave-informationtheory
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef46e7bf4e8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f24e1d192531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=informationtheory
+pkgname=octave-$_pack
+pkgver=0.1.8
+pkgrel=3
+pkgdesc="Functions and routines for basic Information Theory definitions, and source coding."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL')
+groups=('octave-forge')
+depends=('octave>=2.9.7')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('8948c888555cd4377edcc3cdc8611bee')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-informationtheory.install b/octave-informationtheory.install
new file mode 100644
index 000000000000..7f7e24baa3c4
--- /dev/null
+++ b/octave-informationtheory.install
@@ -0,0 +1,17 @@
+_pack=informationtheory
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}