summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 14:55:13 -0500
committerCarlos Aznarán Laos2022-01-24 14:55:13 -0500
commita8954489480855cea9fa6e2d4786d933fff0738a (patch)
tree70bc00ee5da02a18b7c8f859cd97d4f8d4767dcc
parent05f479ce61a948020036edce79bb375f0567573b (diff)
downloadaur-a8954489480855cea9fa6e2d4786d933fff0738a.tar.gz
Version bump to 0.1.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD54
2 files changed, 34 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 580098c3df62..92ceaff4fec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Wed Mar 20 06:11:11 UTC 2019
pkgbase = octave-lssa
- pkgdesc = A package implementing tools to compute spectral decompositions of irregularly-spaced time series. Currently includes functions based off the Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C (see URLs).
- pkgver = 0.1.3
+ pkgdesc = A package implementing tools to compute spectral decompositions of irregularly-spaced time series. Currently includes functions based off the Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C
+ pkgver = 0.1.4
pkgrel = 1
- url = http://octave.sourceforge.net/lssa/
+ url = https://octave.sourceforge.io/lssa
install = octave-lssa.install
arch = any
groups = octave-forge
license = GPL3
depends = octave>=3.6.0
- noextract = lssa-0.1.3.tar.gz
- source = http://downloads.sourceforge.net/octave/lssa-0.1.3.tar.gz
- md5sums = bf0d72b93cca9d37b5d21a309c14ef2a
+ noextract = lssa-0.1.4.tar.gz
+ source = https://downloads.sourceforge.net/octave/lssa-0.1.4.tar.gz
+ sha512sums = dfda6f14bca8164c915442c52a845fad323ec60e445df3c1461e40ff6b887a5ebe81a207bc4756eb58a1d26a27780b67f052a4986eb20f6e5c20ddc8293ec87d
pkgname = octave-lssa
-
diff --git a/PKGBUILD b/PKGBUILD
index fcffa15412ea..225bd25ca612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
-# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -8,12 +9,12 @@
#
_pack=lssa
-pkgname=octave-$_pack
-pkgver=0.1.3
+pkgname=octave-${_pack}
+pkgver=0.1.4
pkgrel=1
-pkgdesc="A package implementing tools to compute spectral decompositions of irregularly-spaced time series. Currently includes functions based off the Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C (see URLs). "
+pkgdesc="A package implementing tools to compute spectral decompositions of irregularly-spaced time series. Currently includes functions based off the Lomb-Scargle periodogram and Adolf Mathias' implementation for R and C"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=3.6.0')
@@ -21,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('bf0d72b93cca9d37b5d21a309c14ef2a')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('dfda6f14bca8164c915442c52a845fad323ec60e445df3c1461e40ff6b887a5ebe81a207bc4756eb58a1d26a27780b67f052a4986eb20f6e5c20ddc8293ec87d')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}