summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 21:14:48 +0800
committerwangjiezhe2015-10-27 21:19:01 +0800
commit4db6629e28c906e9b2d073dd0e56f09e7c37083e (patch)
tree701beb1f0376696fe760d9566c5043c113604ae2
downloadaur-4db6629e28c906e9b2d073dd0e56f09e7c37083e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-ltfat.install17
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0e18bd73dca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = octave-ltfat
+ pkgdesc = The Large Time/Frequency Analysis Toolbox (LTFAT) is a Matlab/Octave toolbox for working with time-frequency analysis, wavelets and signal processing. It is intended both as an educational and a computational tool. The toolbox provides a large numbe [...]
+ pkgver = 2.1.1
+ pkgrel = 2
+ url = http://octave.sourceforge.net/ltfat/
+ install = octave-ltfat.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ makedepends = fftw
+ makedepends = lapack
+ makedepends = blas
+ makedepends = portaudio
+ depends = octave>=3.8.0
+ noextract = ltfat-2.1.1.tar.gz
+ source = http://downloads.sourceforge.net/octave/ltfat-2.1.1.tar.gz
+ md5sums = 3365222fa5736f84240678f1690f37f2
+
+pkgname = octave-ltfat
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08be717d3fb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=ltfat
+pkgname=octave-$_pack
+pkgver=2.1.1
+pkgrel=2
+pkgdesc="The Large Time/Frequency Analysis Toolbox (LTFAT) is a Matlab/Octave toolbox for working with time-frequency analysis, wavelets and signal processing. It is intended both as an educational and a computational tool. The toolbox provides a large numbe [...]"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.8.0')
+makedepends=('fftw' 'lapack' 'blas' 'portaudio')
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('3365222fa5736f84240678f1690f37f2')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-ltfat.install b/octave-ltfat.install
new file mode 100644
index 000000000000..5c1230565e21
--- /dev/null
+++ b/octave-ltfat.install
@@ -0,0 +1,17 @@
+_pack=ltfat
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}