summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-12-14 20:42:46 +0800
committerwangjiezhe2015-12-14 20:42:46 +0800
commitafee33207a3347c2b901dc42db4fa1f5a3cfc399 (patch)
tree990e773ed4aad22b955745cb6bd074da4736439d
parent0f4286c280f16b110735cff01cd40f76ced37bf3 (diff)
downloadaur-afee33207a3347c2b901dc42db4fa1f5a3cfc399.tar.gz
C++11 ABI rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--octave-miscellaneous.install8
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9851e4820589..a63392d11c2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 12:42:42 UTC 2015
pkgbase = octave-miscellaneous
pkgdesc = Miscellaneous tools that don't fit somewhere else.
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 4
url = http://octave.sourceforge.net/miscellaneous/
install = octave-miscellaneous.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c3f8d6736612..061802717b8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pack=miscellaneous
pkgname=octave-$_pack
pkgver=1.2.1
-pkgrel=2
+pkgrel=4
pkgdesc="Miscellaneous tools that don't fit somewhere else."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -28,6 +28,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('d205946284d56a03b06fea1cdf302efb')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -40,7 +44,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-miscellaneous.install b/octave-miscellaneous.install
index badb4f189585..52cac0bff214 100644
--- a/octave-miscellaneous.install
+++ b/octave-miscellaneous.install
@@ -1,7 +1,11 @@
_pack=miscellaneous
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}