summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-22 11:06:01 -0500
committerCarlos Aznarán Laos2022-01-22 11:06:01 -0500
commit9dbe98adcd8bcae10e9fc0462ed0dcdb3fe5e261 (patch)
tree3d24f73437671035e8805e87ca54da477c4383d5
parentfa5b360daca2ec2003fd04bdf02485d9d9465692 (diff)
downloadaur-9dbe98adcd8bcae10e9fc0462ed0dcdb3fe5e261.tar.gz
Update upstream URL and source URL
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD51
2 files changed, 31 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65e11d173f59..b515fbbedf3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Dec 29 05:45:18 UTC 2016
pkgbase = octave-msh
pkgdesc = Create and manage triangular and tetrahedral meshes for Finite Element or Finite Volume PDE solvers. Use a mesh data structure compatible with PDEtool. Rely on gmsh for unstructured mesh generation.
pkgver = 1.0.10
pkgrel = 5
- url = http://octave.sourceforge.net/msh/
+ url = https://octave.sourceforge.io/msh
install = octave-msh.install
arch = any
groups = octave-forge
- license = GPL
+ license = GPL2
depends = octave>=3.0
depends = octave-splines
optdepends = gmsh>=1.6.5
optdepends = awk
optdepends = dolfin
noextract = msh-1.0.10.tar.gz
- source = http://downloads.sourceforge.net/octave/msh-1.0.10.tar.gz
- md5sums = a7cddc41148d8456b46bc84f98284629
+ source = https://downloads.sourceforge.net/octave/msh-1.0.10.tar.gz
+ sha512sums = 6fd1983d19feb5130725be6157d3316d15268487677312391f7c3d067af7c9868408f42e38f2550fc62715c926cd36290cdea0fde81e96f3820f3336109d4094
pkgname = octave-msh
-
diff --git a/PKGBUILD b/PKGBUILD
index af0fa53b528e..3e38e443a63f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,52 +9,53 @@
#
_pack=msh
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.0.10
pkgrel=5
pkgdesc="Create and manage triangular and tetrahedral meshes for Finite Element or Finite Volume PDE solvers. Use a mesh data structure compatible with PDEtool. Rely on gmsh for unstructured mesh generation."
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
-license=('GPL')
+url="https://octave.sourceforge.io/${_pack}"
+license=('GPL2')
groups=('octave-forge')
depends=('octave>=3.0' 'octave-splines')
makedepends=()
optdepends=('gmsh>=1.6.5' 'awk' 'dolfin')
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('a7cddc41148d8456b46bc84f98284629')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('6fd1983d19feb5130725be6157d3316d15268487677312391f7c3d067af7c9868408f42e38f2550fc62715c926cd36290cdea0fde81e96f3820f3336109d4094')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}