summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 21:25:26 +0800
committerwangjiezhe2015-10-27 21:25:26 +0800
commit4b22c0e680ccf16b86e6c59fb29fb8dcc6a39fbe (patch)
tree37dca18e6548cebf9e0779b0b761d2336b261faf
parentc91c28d30529973a3fe99afc66009a8a724d2b6a (diff)
downloadaur-4b22c0e680ccf16b86e6c59fb29fb8dcc6a39fbe.tar.gz
Use _octave_run
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--octave-mvn.install8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bee55c8358b2..1e9431537c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octave-mvn
pkgdesc = Multivariate normal distribution clustering and utility functions.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://octave.sourceforge.net/mvn/
install = octave-mvn.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 8399a12d60ae..525f14ea878c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pack=mvn
pkgname=octave-$_pack
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Multivariate normal distribution clustering and utility functions."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -27,6 +27,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('13039ee507519eda19bc2952ea33c535')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -39,7 +43,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave-cli -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-mvn.install b/octave-mvn.install
index 6d04c66e7a5c..c1fbf4e94020 100644
--- a/octave-mvn.install
+++ b/octave-mvn.install
@@ -1,7 +1,11 @@
_pack=mvn
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave-cli -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave-cli -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}