summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 11:41:05 +0800
committerwangjiezhe2015-10-27 11:41:05 +0800
commit0c52194960372230f26eb6edecaa78cd36f4f316 (patch)
tree8eae25eb3c8dd03c95e8a63698dc94c39ca0efc7
downloadaur-0c52194960372230f26eb6edecaa78cd36f4f316.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--octave-ncarray.install13
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba900ddf339b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = octave-ncarray
+ pkgdesc = Access a single or a collection of NetCDF files as a multi-dimensional array
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = http://octave.sourceforge.net/ncarray/
+ install = octave-ncarray.install
+ arch = any
+ groups = octave-forge
+ license = GPL
+ depends = octave>=3.4.0
+ depends = octave-netcdf>=1.0.2
+ depends = octave-statistics>=1.0.6
+ noextract = ncarray-1.0.3.tar.gz
+ source = http://downloads.sourceforge.net/octave/ncarray-1.0.3.tar.gz
+ md5sums = 18f563063a589871f3d6aa56a5fb8c49
+
+pkgname = octave-ncarray
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9427b97d66f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=ncarray
+pkgname=octave-$_pack
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Access a single or a collection of NetCDF files as a multi-dimensional array"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL')
+groups=('octave-forge')
+depends=('octave>=3.4.0' 'octave-netcdf>=1.0.2' 'octave-statistics>=1.0.6')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('18f563063a589871f3d6aa56a5fb8c49')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-ncarray.install b/octave-ncarray.install
new file mode 100644
index 000000000000..5fa6c612a3b7
--- /dev/null
+++ b/octave-ncarray.install
@@ -0,0 +1,13 @@
+_pack=ncarray
+
+post_install() {
+ octave-cli -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave-cli -q -f --eval "pkg rebuild -global"
+}