summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 21:29:55 +0800
committerwangjiezhe2015-10-27 21:29:55 +0800
commit96e8aefb3f96d1f92b2ebb376cc0416e73843315 (patch)
tree9ad11bd0a6d987aaac313b3b5678890115343c79
downloadaur-96e8aefb3f96d1f92b2ebb376cc0416e73843315.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-nurbs.install17
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f1f139b9319
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-nurbs
+ pkgdesc = Collection of routines for the creation, and manipulation of Non-Uniform Rational B-Splines (NURBS), based on the NURBS toolbox by Mark Spink.
+ pkgver = 1.3.10
+ pkgrel = 2
+ url = http://octave.sourceforge.net/nurbs/
+ install = octave-nurbs.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ depends = octave>=3.8
+ noextract = nurbs-1.3.10.tar.gz
+ source = http://downloads.sourceforge.net/octave/nurbs-1.3.10.tar.gz
+ md5sums = f64844982761a1afff9a356b11f91089
+
+pkgname = octave-nurbs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7603109d93e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=nurbs
+pkgname=octave-$_pack
+pkgver=1.3.10
+pkgrel=2
+pkgdesc="Collection of routines for the creation, and manipulation of Non-Uniform Rational B-Splines (NURBS), based on the NURBS toolbox by Mark Spink."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.8')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('f64844982761a1afff9a356b11f91089')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-nurbs.install b/octave-nurbs.install
new file mode 100644
index 000000000000..326ae6ec0121
--- /dev/null
+++ b/octave-nurbs.install
@@ -0,0 +1,17 @@
+_pack=nurbs
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}