summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-06-10 10:24:25 +0200
committerClemens Buchacher2015-06-10 10:24:25 +0200
commita5394470ea175fd531a74803a7a5fe3ffa1e6378 (patch)
tree4ffe462788164439feea66838f5d44ae783d03af
downloadaur-a5394470ea175fd531a74803a7a5fe3ffa1e6378.tar.gz
octcdf 1.1.8-2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rw-r--r--octave-octcdf.install13
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ea8537266a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = octave-octcdf
+ pkgdesc = A NetCDF interface for octave. This interface is depreciated. Please use the netcdf package instead (possibly in combination with ncarray).
+ pkgver = 1.1.8
+ pkgrel = 2
+ url = http://octave.sourceforge.net/octcdf/
+ install = octave-octcdf.install
+ arch = any
+ groups = octave-forge
+ license = GPL
+ makedepends = netcdf
+ depends = octave>=3.4.0
+ noextract = octcdf-1.1.8.tar.gz
+ source = http://downloads.sourceforge.net/octave/octcdf-1.1.8.tar.gz
+ md5sums = 981f0937cdf45415f966ea1886ba8136
+
+pkgname = octave-octcdf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9206ed31887e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+*/src/
+*/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36811d8add11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=octcdf
+pkgname=octave-$_pack
+pkgver=1.1.8
+pkgrel=2
+pkgdesc="A NetCDF interface for octave. This interface is depreciated. Please use the netcdf package instead (possibly in combination with ncarray)."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL')
+groups=('octave-forge')
+depends=('octave>=3.4.0')
+makedepends=('netcdf')
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('981f0937cdf45415f966ea1886ba8136')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-octcdf.install b/octave-octcdf.install
new file mode 100644
index 000000000000..2bfaa90b28c5
--- /dev/null
+++ b/octave-octcdf.install
@@ -0,0 +1,13 @@
+_pack=octcdf
+
+post_install() {
+ octave -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave -q -f --eval "pkg rebuild -global"
+}