summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-28 10:53:28 +0800
committerwangjiezhe2015-10-28 10:53:28 +0800
commit382674d838c19a49815f7780771c3731c38bfe9a (patch)
tree22674bb0dc3d09a3faac73b378628f566a301f44
downloadaur-382674d838c19a49815f7780771c3731c38bfe9a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-octclip.install17
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..358aa42b0552
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-octclip
+ pkgdesc = This package allows to do boolean operations with polygons using the Greiner-Hormann algorithm.
+ pkgver = 1.0.8
+ pkgrel = 2
+ url = http://octave.sourceforge.net/octclip/
+ install = octave-octclip.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=2.9.7
+ noextract = octclip-1.0.8.tar.gz
+ source = http://downloads.sourceforge.net/octave/octclip-1.0.8.tar.gz
+ md5sums = 762a9624798158be07d682eb9a05c80c
+
+pkgname = octave-octclip
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6777a1146aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=octclip
+pkgname=octave-$_pack
+pkgver=1.0.8
+pkgrel=2
+pkgdesc="This package allows to do boolean operations with polygons using the Greiner-Hormann algorithm."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=2.9.7')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('762a9624798158be07d682eb9a05c80c')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-octclip.install b/octave-octclip.install
new file mode 100644
index 000000000000..d1165a98b630
--- /dev/null
+++ b/octave-octclip.install
@@ -0,0 +1,17 @@
+_pack=octclip
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}