summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 17:58:02 -0500
committerCarlos Aznarán Laos2022-01-24 17:58:02 -0500
commit15d4744970494562bdab3773706fc7f84711229b (patch)
treee638e3a6128f9f526ab6fc103f05ae89a8dd118b
parentc633d364423d83dc5e16e714fd029616c1d71894 (diff)
downloadaur-15d4744970494562bdab3773706fc7f84711229b.tar.gz
Version bump to 2.0.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD57
2 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d9a34d294f..62a4c015d10c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Dec 29 06:03:13 UTC 2016
pkgbase = octave-octproj
- pkgdesc = This package allows to call functions of PROJ.4 library for cartographic projections transformations.
- pkgver = 1.1.5
- pkgrel = 4
- url = http://octave.sourceforge.net/octproj/
+ pkgdesc = This package allows to call functions of PROJ library for cartographic projections and CRS transformations
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://octave.sourceforge.io/octproj
install = octave-octproj.install
arch = any
groups = octave-forge
license = GPL3
- depends = octave>=2.9.7
+ depends = octave>=3.0.0
depends = proj
- noextract = octproj-1.1.5.tar.gz
- source = http://downloads.sourceforge.net/octave/octproj-1.1.5.tar.gz
- md5sums = e8a38175fb4a6fe0bf2c0917f55c78b9
+ noextract = octproj-2.0.1.tar.gz
+ source = https://downloads.sourceforge.net/octave/octproj-2.0.1.tar.gz
+ sha512sums = 98e1ff7b289b8928efefc95b88aee7cdf09135b05c21fb5d90e11e937622d7c077c6c0a0dae4680648c7f76ba75dee39e4f53e94875b08d830c0ddbe9cf94c1e
pkgname = octave-octproj
-
diff --git a/PKGBUILD b/PKGBUILD
index 5d43648c9009..9996bbeec15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,52 +9,53 @@
#
_pack=octproj
-pkgname=octave-$_pack
-pkgver=1.1.5
-pkgrel=4
-pkgdesc="This package allows to call functions of PROJ.4 library for cartographic projections transformations."
+pkgname=octave-${_pack}
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="This package allows to call functions of PROJ library for cartographic projections and CRS transformations"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
-depends=('octave>=2.9.7' 'proj')
+depends=('octave>=3.0.0' 'proj')
makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('e8a38175fb4a6fe0bf2c0917f55c78b9')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('98e1ff7b289b8928efefc95b88aee7cdf09135b05c21fb5d90e11e937622d7c077c6c0a0dae4680648c7f76ba75dee39e4f53e94875b08d830c0ddbe9cf94c1e')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}