summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 18:33:39 -0500
committerCarlos Aznarán Laos2022-01-24 18:33:39 -0500
commite2c1d7ffce27fcf824de269f3a7f7bcb44f2955c (patch)
tree2bf8924e7d2aaa59107c4b4d797301a738651c1e
parent56978e885cac2dac0cfb559fd517ed7e85641b71 (diff)
downloadaur-e2c1d7ffce27fcf824de269f3a7f7bcb44f2955c.tar.gz
Version bump to 1.2.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD57
2 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 017284a8c722..d240391b5873 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Dec 29 06:16:25 UTC 2016
pkgbase = octave-sockets
- pkgdesc = Socket functions for networking from within octave.
- pkgver = 1.2.0
- pkgrel = 4
- url = http://octave.sourceforge.net/sockets/
+ pkgdesc = Socket functions for networking from within octave
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://octave.sourceforge.io/sockets
install = octave-sockets.install
arch = any
groups = octave-forge
license = GPL3
- depends = octave>=3.2.0
- noextract = sockets-1.2.0.tar.gz
- source = http://downloads.sourceforge.net/octave/sockets-1.2.0.tar.gz
- md5sums = 637587b1656fffe2bdcf1d30017f014f
+ depends = octave>=3.6.0
+ noextract = sockets-1.2.1.tar.gz
+ source = https://downloads.sourceforge.net/octave/sockets-1.2.1.tar.gz
+ sha512sums = 9a0b44705d5fe4c7f7d991eb5956d83733a49af1976b5e57cb854c5eec855bb342e4b98009bc156e25860088dffdcdac4bcf7b882359e6c7ec7e4daafcb57bd9
pkgname = octave-sockets
-
diff --git a/PKGBUILD b/PKGBUILD
index 42aa2682cd16..2f8a800b69f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,52 +9,53 @@
#
_pack=sockets
-pkgname=octave-$_pack
-pkgver=1.2.0
-pkgrel=4
-pkgdesc="Socket functions for networking from within octave."
+pkgname=octave-${_pack}
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Socket functions for networking from within octave"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
-depends=('octave>=3.2.0')
+depends=('octave>=3.6.0')
makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('637587b1656fffe2bdcf1d30017f014f')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('9a0b44705d5fe4c7f7d991eb5956d83733a49af1976b5e57cb854c5eec855bb342e4b98009bc156e25860088dffdcdac4bcf7b882359e6c7ec7e4daafcb57bd9')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}