summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-06-10 10:46:18 +0200
committerClemens Buchacher2015-06-10 10:46:18 +0200
commit7ff7e30209a89fdb7ad272f4f60fe5c3c57deb22 (patch)
tree4e67b3555c3753d569abcb46d7b4d6ee782b48f0
downloadaur-7ff7e30209a89fdb7ad272f4f60fe5c3c57deb22.tar.gz
specfun 1.1.0-3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rw-r--r--octave-specfun.install13
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c55f0f9a787b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-specfun
+ pkgdesc = Special functions including ellipitic functions, etc
+ pkgver = 1.1.0
+ pkgrel = 3
+ url = http://octave.sourceforge.net/specfun/
+ install = octave-specfun.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=3.4.0
+ noextract = specfun-1.1.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/specfun-1.1.0.tar.gz
+ md5sums = eef8c1ff37b05d5e3388ecedc045d53a
+
+pkgname = octave-specfun
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef46e7bf4e8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e46b585831e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=specfun
+pkgname=octave-$_pack
+pkgver=1.1.0
+pkgrel=3
+pkgdesc="Special functions including ellipitic functions, etc"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=3.4.0')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('eef8c1ff37b05d5e3388ecedc045d53a')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-specfun.install b/octave-specfun.install
new file mode 100644
index 000000000000..70146cb0fa91
--- /dev/null
+++ b/octave-specfun.install
@@ -0,0 +1,13 @@
+_pack=specfun
+
+post_install() {
+ octave -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave -q -f --eval "pkg rebuild -global"
+}