summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-12-14 21:00:59 +0800
committerwangjiezhe2015-12-14 21:00:59 +0800
commitecf10eb14d607467741bba507e3a8ccc49b24e07 (patch)
tree5d23b1d6359bff82ca9df69d414865795eec8ec0
parent7ff7e30209a89fdb7ad272f4f60fe5c3c57deb22 (diff)
downloadaur-ecf10eb14d607467741bba507e3a8ccc49b24e07.tar.gz
C++11 ABI rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--octave-specfun.install8
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c55f0f9a787b..e3c11e5d87a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 13:00:53 UTC 2015
pkgbase = octave-specfun
pkgdesc = Special functions including ellipitic functions, etc
pkgver = 1.1.0
- pkgrel = 3
+ pkgrel = 5
url = http://octave.sourceforge.net/specfun/
install = octave-specfun.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4e46b585831e..016472e31eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pack=specfun
pkgname=octave-$_pack
pkgver=1.1.0
-pkgrel=3
+pkgrel=5
pkgdesc="Special functions including ellipitic functions, etc"
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -26,6 +26,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('eef8c1ff37b05d5e3388ecedc045d53a')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-specfun.install b/octave-specfun.install
index 70146cb0fa91..b354f24edf8a 100644
--- a/octave-specfun.install
+++ b/octave-specfun.install
@@ -1,7 +1,11 @@
_pack=specfun
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}