summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 18:37:31 -0500
committerCarlos Aznarán Laos2022-01-24 18:37:31 -0500
commitf3335d2c69accbfe2aedf3c4b37ebba7c38b818c (patch)
treed7e74fe803b6e986ceb0a05917933877b0c5737f
parent2b741e6e465b191d7ab54d73f5f49bc2f806862a (diff)
downloadaur-f3335d2c69accbfe2aedf3c4b37ebba7c38b818c.tar.gz
Update upstream URL
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f110054c4a..6a35470e6746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Dec 29 06:20:48 UTC 2016
pkgbase = octave-specfun
pkgdesc = Special functions including ellipitic functions, etc
pkgver = 1.1.0
pkgrel = 6
- url = http://octave.sourceforge.net/specfun/
+ url = https://octave.sourceforge.io/specfun
install = octave-specfun.install
arch = any
groups = octave-forge
license = custom
depends = octave>=3.4.0
noextract = specfun-1.1.0.tar.gz
- source = http://downloads.sourceforge.net/octave/specfun-1.1.0.tar.gz
- md5sums = eef8c1ff37b05d5e3388ecedc045d53a
+ source = https://downloads.sourceforge.net/octave/specfun-1.1.0.tar.gz
+ sha512sums = 106fb7fd4504704cf30c27f2d900dea2468dccd3b48fbefa9e7509e33c3f74d93ae1e3fcc857142e4d4f99b546b0bcc81c13c095abab83b7844385606497c2c5
pkgname = octave-specfun
-
diff --git a/PKGBUILD b/PKGBUILD
index 2867b4fa9878..4256c2bdc103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,12 +9,12 @@
#
_pack=specfun
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.1.0
pkgrel=6
pkgdesc="Special functions including ellipitic functions, etc"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('custom')
groups=('octave-forge')
depends=('octave>=3.4.0')
@@ -20,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('eef8c1ff37b05d5e3388ecedc045d53a')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('106fb7fd4504704cf30c27f2d900dea2468dccd3b48fbefa9e7509e33c3f74d93ae1e3fcc857142e4d4f99b546b0bcc81c13c095abab83b7844385606497c2c5')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}