summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-22 10:52:58 -0500
committerCarlos Aznarán Laos2022-01-22 10:52:58 -0500
commit0e75d7aeaa16478d0402f4e0938362bacad0617b (patch)
tree7135cfb5101ba0cddd0d21141d8667e935de1c96
parent3e5a0ff7dcc94ae75bad8e57f1ee27e56d4b5f6f (diff)
downloadaur-0e75d7aeaa16478d0402f4e0938362bacad0617b.tar.gz
Version bump to 1.3.4
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD54
-rw-r--r--octave-splines.install17
4 files changed, 56 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1930b01954b4..e5c67484207e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Jun 29 04:19:33 UTC 2017
pkgbase = octave-splines
- pkgdesc = Additional spline functions.
- pkgver = 1.3.2
- pkgrel = 2
- url = http://octave.sourceforge.net/splines/
+ pkgdesc = Additional spline functions
+ pkgver = 1.3.4
+ pkgrel = 1
+ url = https://octave.sourceforge.io/splines
install = octave-splines.install
arch = any
groups = octave-forge
license = custom
depends = octave>=3.6.0
- noextract = splines-1.3.2.tar.gz
- source = http://downloads.sourceforge.net/octave/splines-1.3.2.tar.gz
- md5sums = f682724bd68820d83c4e560fc49e144f
- sha1sums = 49339e5ba31514d1c37871781bca13ef296bf087
+ noextract = splines-1.3.4.tar.gz
+ source = https://downloads.sourceforge.net/octave/splines-1.3.4.tar.gz
+ sha512sums = ca506df2b00acc94d291cc70a8601a950d73c3fe03308e4d6c1e9ababdd4f73312680e1e59a8769616300338b8623e687475d37815cf176d4eb9f32c4dedc6a0
pkgname = octave-splines
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e89fde17aa5d..c1d3d411ee56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,7 @@
+#
# Maintainer: MadPhysicist <jfoxrabinovitz at gmail dot com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Joseph Fox-Rabinovitz <jfoxrabinovitz@gmail.com>
# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
@@ -7,12 +10,12 @@
#
_pack=splines
-pkgname=octave-$_pack
-pkgver=1.3.2
-pkgrel=2
-pkgdesc="Additional spline functions."
+pkgname=octave-${_pack}
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="Additional spline functions"
arch=(any)
-url="http://octave.sourceforge.net/${_pack}/"
+url="https://octave.sourceforge.io/${_pack}"
license=('custom')
groups=('octave-forge')
depends=('octave>=3.6.0')
@@ -20,15 +23,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install="${pkgname}.install"
-_archive="${_pack}-${pkgver}.tar.gz"
-source=("http://downloads.sourceforge.net/octave/${_archive}")
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
noextract=("${_archive}")
-sha1sums=('49339e5ba31514d1c37871781bca13ef296bf087')
-md5sums=('f682724bd68820d83c4e560fc49e144f')
+sha512sums=('ca506df2b00acc94d291cc70a8601a950d73c3fe03308e4d6c1e9ababdd4f73312680e1e59a8769616300338b8623e687475d37815cf176d4eb9f32c4dedc6a0')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
package() {
- mkdir -p "${pkgdir}/usr/share/octave/packages"
- mkdir -p "${pkgdir}/usr/lib/octave/packages"
- cp "${srcdir}/${_archive}" "${pkgdir}/usr/share/octave/${_pack}.tar.gz"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}
diff --git a/octave-splines.install b/octave-splines.install
index 8cce2f252760..0e3daee753a6 100644
--- a/octave-splines.install
+++ b/octave-splines.install
@@ -1,20 +1,17 @@
_pack=splines
-_prefix=/usr/share/octave/packages
-_libdir=/usr/lib/octave/packages
-## arg 1: the new package version
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave-cli -q -f --eval "pkg prefix $_prefix $_libdir; pkg install -verbose -global /usr/share/octave/$_pack.tar.gz"
+ _octave_run "pkg rebuild -global $_pack"
}
-## arg 1: the new package version
-## arg 2: the old package version
post_upgrade() {
- post_remove
post_install
}
-## arg 1: the old package version
post_remove() {
- octave-cli -q -f --eval "pkg prefix $_prefix $_libdir; pkg uninstall $_pack; pkg rebuild -global"
-}
+ _octave_run "pkg rebuild -global"
+} \ No newline at end of file