summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Fox-Rabinovitz2015-07-31 16:52:00 -0400
committerJoseph Fox-Rabinovitz2015-07-31 16:52:00 -0400
commit22b24be69766b0b05415c3780f01da4c4e31d2db (patch)
treeddec4ea3c100d0b28998a7ab8d1dfbd8ba4c10a6
downloadaur-22b24be69766b0b05415c3780f01da4c4e31d2db.tar.gz
Initial adoption commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--octave-splines.install20
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fc28919d0f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = octave-splines
+ pkgdesc = Additional spline functions.
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = http://octave.sourceforge.net/splines/
+ install = octave-splines.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=3.6.0
+ noextract = splines-1.2.8.tar.gz
+ source = http://downloads.sourceforge.net/octave/splines-1.2.8.tar.gz
+ md5sums = ef569ae0257586e608bc0af54e811978
+ sha1sums = 9b4824aa26b8b49c46fe6937e46a01a25451dcc5
+
+pkgname = octave-splines
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3058b1638eb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: MadPhysicist <jfoxrabinovitz at gmail dot com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=splines
+pkgname=octave-$_pack
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="Additional spline functions."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=3.6.0')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+sha1sums=('9b4824aa26b8b49c46fe6937e46a01a25451dcc5')
+md5sums=('ef569ae0257586e608bc0af54e811978')
+
+build() {
+ cd "$srcdir"
+ mkdir -p builddir
+ octave -q -f --eval "pkg build -verbose -nodeps builddir $_archive"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/octave/packages"
+ mkdir -p "$pkgdir/usr/lib/octave/packages"
+ cp "$srcdir/builddir/$_archive" "$pkgdir/usr/share/octave/$_pack.tar.gz"
+}
diff --git a/octave-splines.install b/octave-splines.install
new file mode 100644
index 000000000000..7234bd2862bd
--- /dev/null
+++ b/octave-splines.install
@@ -0,0 +1,20 @@
+_pack=splines
+_prefix=/usr/share/octave/packages
+_libdir=/usr/lib/octave/packages
+
+## arg 1: the new package version
+post_install() {
+ octave -q -f --eval "pkg prefix $prefix $libdir; pkg install -verbose -global /usr/share/octave/$_pack.tar.gz"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_remove
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ octave -q -f --eval "pkg prefix $prefix $libdir; pkg uninstall $_pack; pkg rebuild -global"
+}