summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-28 12:15:41 +0800
committerwangjiezhe2015-10-28 12:15:41 +0800
commit7990395809e58294bf635dc1c3fb6316a6f9a64d (patch)
tree3a981c14445b1ffe336618f7346190d3dc2d1c2d
parentdab84d9d3b6a13dd874f3ed02907636da2a1d98d (diff)
downloadaur-7990395809e58294bf635dc1c3fb6316a6f9a64d.tar.gz
Use _octave_run
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--octave-stk.install8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 339788211975..5f2a2567df57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octave-stk
pkgdesc = The STK is a (not so) Small Toolbox for Kriging. Its primary focus is on the interpolation/regression technique known as kriging, which is very closely related to Splines and Radial Basis Functions, and can be interpreted as a non-parametric Bayesi [...]
pkgver = 2.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://octave.sourceforge.net/stk/
install = octave-stk.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index a4f0a74cc7a1..6b8244fee6eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pack=stk
pkgname=octave-$_pack
pkgver=2.3.3
-pkgrel=1
+pkgrel=2
pkgdesc=" The STK is a (not so) Small Toolbox for Kriging. Its primary focus is on the interpolation/regression technique known as kriging, which is very closely related to Splines and Radial Basis Functions, and can be interpreted as a non-parametric Bayesi [...]"
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -27,6 +27,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('121672ef8e39cca5ff2439b8e85a0d71')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -39,7 +43,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave-cli -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-stk.install b/octave-stk.install
index 18323e5368dc..7d868eab342a 100644
--- a/octave-stk.install
+++ b/octave-stk.install
@@ -1,7 +1,11 @@
_pack=stk
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave-cli -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave-cli -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}