summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 12:12:07 +0800
committerwangjiezhe2015-10-27 12:17:01 +0800
commitdab84d9d3b6a13dd874f3ed02907636da2a1d98d (patch)
tree78fc4ce9a0c12ce74bd9d5d7e80d7f4ce78ef15c
downloadaur-dab84d9d3b6a13dd874f3ed02907636da2a1d98d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--octave-stk.install13
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..339788211975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = octave-stk
+ pkgdesc = The STK is a (not so) Small Toolbox for Kriging. Its primary focus is on the interpolation/regression technique known as kriging, which is very closely related to Splines and Radial Basis Functions, and can be interpreted as a non-parametric Bayesi [...]
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = http://octave.sourceforge.net/stk/
+ install = octave-stk.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=3.2.2
+ noextract = stk-2.3.3.tar.gz
+ source = http://downloads.sourceforge.net/octave/stk-2.3.3.tar.gz
+ md5sums = 121672ef8e39cca5ff2439b8e85a0d71
+
+pkgname = octave-stk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4f0a74cc7a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=stk
+pkgname=octave-$_pack
+pkgver=2.3.3
+pkgrel=1
+pkgdesc=" The STK is a (not so) Small Toolbox for Kriging. Its primary focus is on the interpolation/regression technique known as kriging, which is very closely related to Splines and Radial Basis Functions, and can be interpreted as a non-parametric Bayesi [...]"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=3.2.2')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('121672ef8e39cca5ff2439b8e85a0d71')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-stk.install b/octave-stk.install
new file mode 100644
index 000000000000..18323e5368dc
--- /dev/null
+++ b/octave-stk.install
@@ -0,0 +1,13 @@
+_pack=stk
+
+post_install() {
+ octave-cli -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave-cli -q -f --eval "pkg rebuild -global"
+}