summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-12-14 21:02:31 +0800
committerwangjiezhe2015-12-14 21:02:31 +0800
commit5d3cebc0d449088beb069dc3318d422210204a6a (patch)
treef0bcf607b7bfe3994f937a0b10187ecf84bd8871
parentc5b2d7359b087489069f04cd081e06a89605bd10 (diff)
downloadaur-5d3cebc0d449088beb069dc3318d422210204a6a.tar.gz
C++11 ABI rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--octave-struct.install8
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa7281115677..895838ea0d46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 13:02:29 UTC 2015
pkgbase = octave-struct
pkgdesc = Additional Structure manipulations functions.
pkgver = 1.0.11
- pkgrel = 2
+ pkgrel = 4
url = http://octave.sourceforge.net/struct/
install = octave-struct.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b5d3083c73de..d7686315fb38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pack=struct
pkgname=octave-$_pack
pkgver=1.0.11
-pkgrel=2
+pkgrel=4
pkgdesc="Additional Structure manipulations functions."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -26,6 +26,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('5ff3236cca32c691b023944bac45c4fd')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-struct.install b/octave-struct.install
index 41e16f01db18..0a5de7725921 100644
--- a/octave-struct.install
+++ b/octave-struct.install
@@ -1,7 +1,11 @@
_pack=struct
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}