summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-06-23 15:47:17 +0800
committerwangjiezhe2016-06-23 15:47:24 +0800
commitaa7b12277bb19400200933c8529de41bee11c470 (patch)
tree7867ff5a71ae1caed7826f3d407f2a406500cd91
downloadaur-aa7b12277bb19400200933c8529de41bee11c470.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-vibes.install17
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4907db7077a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jun 23 07:46:48 UTC 2016
+pkgbase = octave-vibes
+ pkgdesc = The VIBes API allows one to easily display results (boxes, pavings) from interval methods. VIBes consists in two parts: (1) the VIBes application that features viewing, annotating and exporting figures, and (2) the VIBes API that enables your progr [...]
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://octave.sourceforge.net/vibes/
+ install = octave-vibes.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=4.0.0
+ noextract = vibes-0.2.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/vibes-0.2.0.tar.gz
+ md5sums = c8055e4a00fe1c516e10859cabe590a8
+
+pkgname = octave-vibes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..061e977d5879
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=vibes
+pkgname=octave-$_pack
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="The VIBes API allows one to easily display results (boxes, pavings) from interval methods. VIBes consists in two parts: (1) the VIBes application that features viewing, annotating and exporting figures, and (2) the VIBes API that enables your progr [...]"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=4.0.0')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('c8055e4a00fe1c516e10859cabe590a8')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-vibes.install b/octave-vibes.install
new file mode 100644
index 000000000000..0784dd4c0fad
--- /dev/null
+++ b/octave-vibes.install
@@ -0,0 +1,17 @@
+_pack=vibes
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}