summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 12:51:07 +0800
committerwangjiezhe2015-10-27 12:51:07 +0800
commit763516092f744dfb7b55e06e73b8079583dca76d (patch)
tree9ea52538b9dc63a4fc408c4c526f62d9d814776b
downloadaur-763516092f744dfb7b55e06e73b8079583dca76d.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--octave-vrml.install13
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a71d5242ec72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = octave-vrml
+ pkgdesc = 3D graphics using VRML
+ pkgver = 1.0.13
+ pkgrel = 1
+ url = http://octave.sourceforge.net/vrml/
+ install = octave-vrml.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ makedepends = freewrl
+ depends = octave>=2.9.7
+ depends = octave-linear-algebra
+ depends = octave-miscellaneous
+ depends = octave-struct
+ depends = octave-statistics
+ noextract = vrml-1.0.13.tar.gz
+ source = http://downloads.sourceforge.net/octave/vrml-1.0.13.tar.gz
+ md5sums = 79df290cea3f45e49eb58bfc664679b1
+
+pkgname = octave-vrml
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d4f8e380e91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=vrml
+pkgname=octave-$_pack
+pkgver=1.0.13
+pkgrel=1
+pkgdesc="3D graphics using VRML"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=2.9.7' 'octave-linear-algebra' 'octave-miscellaneous' 'octave-struct' 'octave-statistics')
+makedepends=('freewrl')
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('79df290cea3f45e49eb58bfc664679b1')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-vrml.install b/octave-vrml.install
new file mode 100644
index 000000000000..09e290b06ca5
--- /dev/null
+++ b/octave-vrml.install
@@ -0,0 +1,13 @@
+_pack=vrml
+
+post_install() {
+ octave-cli -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave-cli -q -f --eval "pkg rebuild -global"
+}