summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzael Reyes2020-10-25 14:01:47 -0700
committerAzael Reyes2020-10-25 14:01:47 -0700
commitde6cbfea7a9b509a7abfb5f539c3f308f4c0e4c7 (patch)
tree3481c458b5234bf3918c93ef4474f99222b41ddd
parentc941d6473e2ec5c503a7aa1585a1746492777133 (diff)
downloadaur-de6cbfea7a9b509a7abfb5f539c3f308f4c0e4c7.tar.gz
updint to 2.8.0-alpha
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD10
2 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c6f649d6bc4..425aa88b4bff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,3 +15,20 @@ pkgbase = octetos-core
pkgname = octetos-core
+pkgbase = octetos-core
+ pkgdesc = C/C++ library to mainly provide Semantic Versioned inplmetation
+ pkgver = 2.8.0
+ pkgrel = 1
+ url = https://github.com/azaeldevel/octetos-core.git
+ arch = x86_64
+ license = GPL
+ depends = gcc
+ depends = bison
+ depends = libconfig
+ depends = perl-xml-parser
+ depends = intltool
+ source = https://github.com/azaeldevel/octetos-core/archive/2.8.0-alpha.tar.gz
+ md5sums = 0d5713f449dd8776a73044992e1fbb11
+
+pkgname = octetos-core
+
diff --git a/PKGBUILD b/PKGBUILD
index 581d20b7433e..b47d5dfc6f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=octetos-core
-pkgver=2.7.3
+pkgver=2.8.0
pkgrel=1
pkgdesc="C/C++ library to mainly provide Semantic Versioned inplmetation"
arch=('x86_64')
@@ -10,17 +10,17 @@ license=('GPL')
url="https://github.com/azaeldevel/octetos-core.git"
depends=('gcc' 'bison' 'libconfig' 'perl-xml-parser' 'intltool')
#backup=('etc/nanorc')
-md5sums=('f36caaccfe81ce0d275a73ab804dca01')
-source=(https://github.com/azaeldevel/octetos-core/archive/2.7.3-alpha.tar.gz)
+md5sums=('0d5713f449dd8776a73044992e1fbb11')
+source=(https://github.com/azaeldevel/$pkgname/archive/$pkgver-alpha.tar.gz)
build() {
- cd octetos-core-2.7.3-alpha
+ cd $pkgname-$pkgver-alpha
autoreconf -fi
./configure --prefix=/usr --sysconfdir=/etc
make
}
package() {
- cd octetos-core-2.7.3-alpha
+ cd $pkgname-$pkgver-alpha
make DESTDIR="${pkgdir}" install
}