summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzael Reyes2020-08-14 21:29:26 -0700
committerAzael Reyes2020-08-14 21:29:26 -0700
commite926859bb461c5ccc736c5e197545c3fc398d060 (patch)
treeb6339e42500f31f570cd0326d82b2a2e3c663b76
downloadaur-e926859bb461c5ccc736c5e197545c3fc398d060.tar.gz
Creating package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1f628cc762f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = octetos-db
+ pkgdesc = C++ library for Database Acces.
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/azaeldevel/octetos-db
+ arch = x86_64
+ license = GPL
+ depends = octetos-core
+ source = https://github.com/azaeldevel/octetos-db/archive/1.3.2-alpha.tar.gz
+ md5sums = e5471c2458e615cb4c92858469d0b588
+
+pkgname = octetos-db
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ebe8ec19dc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Azael Reyes <azael.devel@gmail.com>
+
+
+pkgname=octetos-db
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="C++ library for Database Acces."
+arch=('x86_64')
+license=('GPL')
+url="https://github.com/azaeldevel/octetos-db"
+depends=('octetos-core')
+#backup=('etc/nanorc')
+md5sums=('e5471c2458e615cb4c92858469d0b588')
+source=(https://github.com/azaeldevel/octetos-db/archive/1.3.2-alpha.tar.gz)
+
+build() {
+ cd octetos-db-1.3.2-alpha
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc --docdir=${datarootdir}/doc/${pkgname}-${pkgver} --with-abstract
+ make
+}
+
+package() {
+ cd octetos-db-1.3.2-alpha
+ make DESTDIR="${pkgdir}" install
+}