summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzael Reyes2020-11-16 09:00:49 -0800
committerAzael Reyes2020-11-16 09:00:49 -0800
commit6b0fd614cdfbc4a5f52887188a7f921e71d02931 (patch)
treeaef698a9a74107bceed68fe6d1ab1ff00ddb9b7d
downloadaur-6b0fd614cdfbc4a5f52887188a7f921e71d02931.tar.gz
fragmenting octetos-db
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8719dab41e8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = octetos-db-abstract
+ pkgdesc = API to access database, abstract component.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/azaeldevel/octetos-db-abstract
+ arch = x86_64
+ license = GPL
+ depends = octetos-core
+ source = https://github.com/azaeldevel/octetos-db-abstract/archive/0.1.2-alpha.tar.gz
+ md5sums = 6af516cd3d515429cf2cf52caa488ac2
+
+pkgname = octetos-db-abstract
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50f205aae253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Azael Reyes <azael.devel@gmail.com>
+
+
+pkgname=octetos-db-abstract
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="API to access database, abstract component."
+arch=('x86_64')
+license=('GPL')
+url="https://github.com/azaeldevel/octetos-db-abstract"
+depends=('octetos-core')
+#backup=('etc/nanorc')
+md5sums=('6af516cd3d515429cf2cf52caa488ac2')
+source=(https://github.com/azaeldevel/${pkgname}/archive/${pkgver}-alpha.tar.gz)
+
+build() {
+ cd ${pkgname}-${pkgver}-alpha
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}-alpha
+ make DESTDIR="${pkgdir}" install
+}