summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-01-23 08:26:38 -0500
committerAndrew Sun2019-01-23 08:26:38 -0500
commit2969f1caf1cfe28480b310005da2ecda7e2b9181 (patch)
tree21568e5177c501bd02d1f908e124808b78df63aa
parent72136a9f53714afbf3ebe911c4c2e06febc4e5ed (diff)
downloadaur-2969f1caf1cfe28480b310005da2ecda7e2b9181.tar.gz
octomap: update to 1.9.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6281c6ec16c8..35838faa3674 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Dec 10 18:31:47 UTC 2015
pkgbase = octomap
pkgdesc = A probabilistic, flexible, and compact 3D mapping library for robotic systems.
- pkgver = 1.7.0
+ pkgver = 1.9.0
pkgrel = 1
url = http://octomap.github.com/
arch = i686
arch = x86_64
- license = New BSD License
+ license = BSD
makedepends = cmake
+ depends = gcc-libs
provides = octomap
conflicts = octomap-git
- source = https://github.com/OctoMap/octomap/archive/v1.7.0.tar.gz
- sha256sums = c5f2f647465be92836697534dd4bb19a9185f541323e2fe09cfaa78cd1d9bf04
+ source = octomap-1.9.0.tar.gz::https://github.com/OctoMap/octomap/archive/v1.9.0.tar.gz
+ sha256sums = 5f81c9a8cbc9526b2e725251cd3a829e5222a28201b394314002146d8b9214dd
pkgname = octomap
diff --git a/PKGBUILD b/PKGBUILD
index f53662af8ae1..66c7bdb66a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Benjamin Chrétien <chretien dot b+arch at gmail dot com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: Benjamin Chrétien <chretien dot b+arch at gmail dot com>
# Contributor: Soo-Hyun Yoo <yoos117@gmail.com>
+
pkgname=octomap
-pkgver=1.7.0
+pkgver=1.9.0
pkgrel=1
pkgdesc="A probabilistic, flexible, and compact 3D mapping library for robotic systems."
arch=('i686' 'x86_64')
url="http://octomap.github.com/"
-license=('New BSD License')
-groups=()
-depends=()
+license=('BSD')
+depends=('gcc-libs')
makedepends=('cmake')
provides=('octomap')
conflicts=('octomap-git')
-source=("https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
-sha256sums=('c5f2f647465be92836697534dd4bb19a9185f541323e2fe09cfaa78cd1d9bf04')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
+sha256sums=('5f81c9a8cbc9526b2e725251cd3a829e5222a28201b394314002146d8b9214dd')
build() {
cd "$srcdir/octomap-$pkgver/octomap"