summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImNtReal2016-04-01 16:39:44 -0400
committerImNtReal2016-04-01 16:39:44 -0400
commit1c6f1d7add45bfefad82b6df2f15b342f8c39613 (patch)
tree3511b024f782dd9e89bee94cc9a3ed9a55050b01
parente273e2a20971ea6ec1c3d41337d077d7aa1cf3d8 (diff)
downloadaur-1c6f1d7add45bfefad82b6df2f15b342f8c39613.tar.gz
0.8.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--enable-kstatus.patch10
3 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b5bd843d6dd..4eada9c58597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Apr 1 20:39:20 UTC 2016
pkgbase = octopi
- pkgver = 0.8.0
+ pkgdesc = a powerful Pacman frontend using Qt libs
+ pkgver = 0.8.1
pkgrel = 1
- url = https://github.com/aarnt/octopi
+ url = http://octopiproject.wordpress.com
+ install = octopi.install
arch = i686
arch = x86_64
license = GPL2
makedepends = qt5-declarative
makedepends = knotifications
makedepends = libnotify
- source = https://github.com/aarnt/octopi/archive/v0.8.0.tar.gz
+ source = https://github.com/aarnt/octopi/archive/v0.8.1.tar.gz
source = octopi-repoeditor.desktop
source = enable-kstatus.patch
- sha256sums = 79ab8a24e3329ab4e5320e03309f44f802336cc00bada0f9a37fae46f5eeb02b
+ sha256sums = e01c6d959e5663797771b95b47951e3ad11a9abbc7cbb009f1f835404c5ff43e
sha256sums = 131f16745df685430db55e54ede6da66aed9b02ca00d6d873a002b2a3e1c90ef
- sha256sums = 81dcbbda0d020607d23f3f8042fa43bfc4318269a55f9327e4995299b59dcb4b
+ sha256sums = 288dd58a8aa98ef5ad901aec600d0a3c36fa81b60d51385bceeadec0c1aa7b01
pkgname = octopi
pkgdesc = A powerful Pacman frontend using Qt5 libs
diff --git a/PKGBUILD b/PKGBUILD
index fdbfd7dc64ba..2e0ed5395e95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
pkgbase=octopi
pkgname=('octopi' 'octopi-notifier' 'octopi-repoeditor' 'octopi-cachecleaner')
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
+pkgdesc="a powerful Pacman frontend using Qt libs"
arch=('i686' 'x86_64')
-url="https://github.com/aarnt/octopi"
+url="http://octopiproject.wordpress.com"
license=('GPL2')
+install=$pkgname.install
makedepends=('qt5-declarative' 'knotifications' 'libnotify')
source=("https://github.com/aarnt/${pkgname}/archive/v${pkgver}.tar.gz"
'octopi-repoeditor.desktop'
'enable-kstatus.patch')
-sha256sums=('79ab8a24e3329ab4e5320e03309f44f802336cc00bada0f9a37fae46f5eeb02b'
+sha256sums=('e01c6d959e5663797771b95b47951e3ad11a9abbc7cbb009f1f835404c5ff43e'
'131f16745df685430db55e54ede6da66aed9b02ca00d6d873a002b2a3e1c90ef'
- '81dcbbda0d020607d23f3f8042fa43bfc4318269a55f9327e4995299b59dcb4b')
+ '288dd58a8aa98ef5ad901aec600d0a3c36fa81b60d51385bceeadec0c1aa7b01')
prepare() {
_cpucount=$(grep -c processor /proc/cpuinfo 2>/dev/null)
@@ -22,7 +24,7 @@ prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- patch -p1 < ../enable-kstatus.patch
+ patch -p0 < ../enable-kstatus.patch
}
build() {
diff --git a/enable-kstatus.patch b/enable-kstatus.patch
index cc88fda68b79..43b8977074fd 100644
--- a/enable-kstatus.patch
+++ b/enable-kstatus.patch
@@ -1,10 +1,10 @@
-diff -Naur octopi-master-current/notifier/octopi-notifier/octopi-notifier.pro octopi-master-current-kstatus/notifier/octopi-notifier/octopi-notifier.pro
---- octopi-master-current/notifier/octopi-notifier/octopi-notifier.pro 2015-08-09 13:12:50.000000000 +0200
-+++ octopi-master-current-kstatus/notifier/octopi-notifier/octopi-notifier.pro 2015-08-14 10:15:02.645977100 +0200
-@@ -7,7 +7,7 @@
- QT += core xml gui network dbus
+diff -Naur notifier/octopi-notifier/octopi-notifier.pro-orig notifier/octopi-notifier/octopi-notifier.pro
+--- notifier/octopi-notifier/octopi-notifier.pro-orig 2016-04-01 16:34:55.541500593 -0400
++++ notifier/octopi-notifier/octopi-notifier.pro 2016-04-01 16:34:59.948205892 -0400
+@@ -8,7 +8,7 @@
# This controls whether octopi-notifier uses KStatusNotifier lib
+ # You SHOULD REALLY enable the following define in plasma 5 desktops!
-#DEFINES += KSTATUS
+DEFINES += KSTATUS