summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2019-11-02 19:57:38 +0100
committerMatMoul2019-11-02 19:57:38 +0100
commitfa2c52df22dbe5eb41155195c7aaf939ac1bf84d (patch)
treedc0b1143386c30ab533266c8cc986ef2e3b5cc8c
parent1539d8cf59b74fa24ee38cbdf48dbfcb0940b617 (diff)
downloadaur-fa2c52df22dbe5eb41155195c7aaf939ac1bf84d.tar.gz
New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e2a410f6730..6b2f2289d033 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = octopi-dev
pkgdesc = A powerful Pacman frontend using Qt5 libs
pkgver = 0.9.0
- pkgrel = 6
+ pkgrel = 7
url = http://octopiproject.wordpress.com
arch = i686
arch = x86_64
license = GPL2
- makedepends = clang
makedepends = qt5-tools
- depends = alpm_octopi_utils>=1.0.1-1
+ depends = alpm_octopi_utils
+ depends = expac
+ depends = pkgfile
depends = qtermwidget
depends = sudo
optdepends = octopi-notifier-qt5: Notifier for Octopi using Qt5 libs
@@ -23,8 +24,8 @@ pkgbase = octopi-dev
provides = octopi-repoeditor
provides = octopi-cachecleaner
conflicts = octopi
- source = octopi-0.9.0-6.tar.gz::https://github.com/aarnt/octopi/archive/7c5e3f9f27529f8a372b17611eeec18cf788c8d7.tar.gz
- sha256sums = 88e3488dcf9035cc754bd4cad34aab8ba68b60f9a19552c63da01738149b472a
+ source = octopi-0.9.0-7.tar.gz::https://github.com/aarnt/octopi/archive/ed0a6c8b822dcc546c56c3f5afe5de3e8b357471.tar.gz
+ sha256sums = 00fa0b882a828973c481d2a5f54e966df0a66e8fcd2a3aad60a3c14b4455143d
pkgname = octopi-dev
diff --git a/PKGBUILD b/PKGBUILD
index e23224e2b061..337ed33a4b2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,19 @@
# Maintainer: MatMoul <matmoul@gmail.com>
+_pkggit=octopi
+_gitcommit=ed0a6c8b822dcc546c56c3f5afe5de3e8b357471
+_gitsha256='00fa0b882a828973c481d2a5f54e966df0a66e8fcd2a3aad60a3c14b4455143d'
+
pkgbase=octopi-dev
pkgname='octopi-dev'
pkgver=0.9.0
-pkgrel=6
+pkgrel=7
pkgdesc="A powerful Pacman frontend using Qt5 libs"
arch=('i686' 'x86_64')
url="http://octopiproject.wordpress.com"
license=('GPL2')
-depends=('alpm_octopi_utils>=1.0.1-1' 'qtermwidget' 'sudo')
-makedepends=('clang' 'qt5-tools')
+depends=('alpm_octopi_utils' 'expac' 'pkgfile' 'qtermwidget' 'sudo')
+makedepends=('qt5-tools')
optdepends=('octopi-notifier-qt5: Notifier for Octopi using Qt5 libs'
'octopi-notifier-frameworks: Notifier for Octopi with Knotifications support'
'pacaur: for AUR support'
@@ -20,34 +24,26 @@ optdepends=('octopi-notifier-qt5: Notifier for Octopi using Qt5 libs'
'pacmanlogviewer: to view pacman log files')
provides=('octopi' 'octopi-repoeditor' 'octopi-cachecleaner')
conflicts=('octopi')
-#conflicts=('octopi-git' 'octopi-kde-git' 'octopi-notifier-noknotify')
-
-_pkggit=octopi
-_gitcommit=7c5e3f9f27529f8a372b17611eeec18cf788c8d7
-
source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
-sha256sums=('88e3488dcf9035cc754bd4cad34aab8ba68b60f9a19552c63da01738149b472a')
+sha256sums=(${_gitsha256})
_subdirs=(helper repoeditor cachecleaner sudo)
prepare() {
cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- # set version for beta
- sed -i -e "s|0.10.0 (dev)|${pkgver}-${pkgrel} (git-${_gitcommit:0:6})|g" src/strconstants.cpp
}
build() {
cd "${srcdir}/${_pkggit}-${_gitcommit}"
echo "Starting build..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro -spec linux-clang
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro
make
for _subdir in ${_subdirs[@]}; do
pushd $_subdir
echo "Building octopi-$_subdir..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" "octopi-$_subdir.pro" -spec linux-clang
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" "octopi-$_subdir.pro"
make
popd
done