summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-01-14 21:54:48 +0100
committerMatMoul2023-01-14 21:54:48 +0100
commit8901b78f4bf43256d914dbc9015633a36b6977f1 (patch)
treec319f1a2c21145833092ade715d68366e89a02f1
parentbfd3642fcb1a002f6dfd83a0c63b1b878d9fc6c4 (diff)
downloadaur-8901b78f4bf43256d914dbc9015633a36b6977f1.tar.gz
Version 0.14.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD45
2 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66b2025f90c9..4745d6dfd2ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,15 +3,13 @@ pkgbase = octopi-notifier-frameworks
pkgver = 0.14.0
pkgrel = 2
url = https://tintaescura.com/projects/octopi/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = qt5-tools
depends = octopi
depends = knotifications
provides = octopi-notifier
- conflicts = octopi-notifier-qt5
- source = octopi-0.14.0-2.tar.gz::https://github.com/aarnt/octopi/archive/0a47127c711c20f9f8f4c42298a25992dbbf98b9.tar.gz
- sha256sums = 41cf58d9fd12143e34b75798cc65ad467aed69257c8e04a7b9cbee77ae01d133
+ source = octopi::https://github.com/aarnt/octopi/archive/refs/tags/v0.14.0.tar.gz
+ sha256sums = 9b548661807fe8eecc20726a4aefa25658c4ce1bf1bc8f51b54829809d76f12d
pkgname = octopi-notifier-frameworks
diff --git a/PKGBUILD b/PKGBUILD
index 4a5f0f0d946b..ef6d0c82b734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,36 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-_pkggit=octopi
-_gitcommit=0a47127c711c20f9f8f4c42298a25992dbbf98b9
-_gitsha256='41cf58d9fd12143e34b75798cc65ad467aed69257c8e04a7b9cbee77ae01d133'
+_githubuser=aarnt
+_githubrepo=octopi
+_pkgtagname=v0.14.0
-pkgbase=octopi-notifier-frameworks
-pkgname=('octopi-notifier-frameworks')
+pkgname=octopi-notifier-frameworks
pkgver=0.14.0
pkgrel=2
-pkgdesc="Notifier for Octopi with Knotifications support"
-arch=('i686' 'x86_64')
+pkgdesc='Notifier for Octopi with Knotifications support'
+arch=('any')
url="https://tintaescura.com/projects/octopi/"
license=('GPL2')
depends=('octopi' 'knotifications')
makedepends=('qt5-tools')
provides=('octopi-notifier')
-conflicts=('octopi-notifier-qt5')
-source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
-sha256sums=(${_gitsha256})
+source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
+sha256sums=('9b548661807fe8eecc20726a4aefa25658c4ce1bf1bc8f51b54829809d76f12d')
prepare() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- # set Knotifications
- sed -e "s|DEFINES += ALPM_BACKEND #KSTATUS|DEFINES += ALPM_BACKEND KSTATUS|" -i notifier/octopi-notifier.pro
+ cd "${_githubrepo}-${pkgver}"
+ sed -e "s|DEFINES += ALPM_BACKEND #KSTATUS|DEFINES += ALPM_BACKEND KSTATUS|" -i notifier/octopi-notifier.pro
}
-
build() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- msg "Building octopi-notifier..."
- cd notifier
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
- make
+ cd "${_githubrepo}-${pkgver}"
+ msg "Building octopi-notifier..."
+ cd notifier
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
+ make
}
package() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- cd notifier
- make INSTALL_ROOT="${pkgdir}" install
+ cd "${_githubrepo}-${pkgver}"
+ cd notifier
+ make INSTALL_ROOT="${pkgdir}" install
}