summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-01-14 20:53:24 +0100
committerMatMoul2023-01-14 20:53:24 +0100
commitfd1dce56946554b6ad1b0a5fd636434ea029d2b3 (patch)
treeb5e9618d08125f6ecc3d2d566fa3e56b1ce265bd
downloadaur-fd1dce56946554b6ad1b0a5fd636434ea029d2b3.tar.gz
Version 0.14.0.r2.a92868c-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16010699da50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = octopi-notifier-frameworks-dev
+ pkgdesc = Notifier for Octopi with Knotifications support
+ pkgver = 0.14.0.r2.a92868c
+ pkgrel = 1
+ url = https://github.com/aarnt/octopi
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = qt5-tools
+ depends = octopi-dev
+ provides = octopi-notifier
+ source = git+https://github.com/aarnt/octopi.git#commit=a92868cbb3df8ca87380800bf29827482baed18b
+ sha256sums = SKIP
+
+pkgname = octopi-notifier-frameworks-dev
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68a9e7a7d656
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=aarnt
+_githubrepo=octopi
+_gitcommit=a92868cbb3df8ca87380800bf29827482baed18b
+
+pkgname=octopi-notifier-frameworks-dev
+pkgver=0.14.0.r2.a92868c
+pkgrel=1
+pkgdesc='Notifier for Octopi with Knotifications support'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+license=('GPL2')
+depends=('octopi-dev')
+makedepends=('git' 'qt5-tools')
+provides=('octopi-notifier')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${_githubrepo}"
+ sed -e "s|DEFINES += ALPM_BACKEND #KSTATUS|DEFINES += ALPM_BACKEND KSTATUS|" -i notifier/octopi-notifier.pro
+}
+build() {
+ cd "${_githubrepo}"
+ msg "Building octopi-notifier..."
+ cd notifier
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
+ make
+}
+
+package() {
+ cd "${_githubrepo}"
+ cd notifier
+ make INSTALL_ROOT="${pkgdir}" install
+}