summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-01-14 20:53:42 +0100
committerMatMoul2023-01-14 20:53:42 +0100
commit60dd1e7da01874c6f633f01d5d7e3c1496e1d966 (patch)
tree70e57bb124848c00d7a28e251e479a55986b4493
downloadaur-60dd1e7da01874c6f633f01d5d7e3c1496e1d966.tar.gz
Version 0.14.0.r2.a92868c-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ef906104e43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = octopi-notifier-qt5-dev
+ pkgdesc = Notifier for Octopi using Qt5 libs
+ pkgver = 0.14.0.r2.a92868c
+ pkgrel = 1
+ url = https://github.com/aarnt/octopi
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = qt5-tools
+ depends = octopi-dev
+ provides = octopi-notifier
+ source = git+https://github.com/aarnt/octopi.git#commit=a92868cbb3df8ca87380800bf29827482baed18b
+ sha256sums = SKIP
+
+pkgname = octopi-notifier-qt5-dev
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..212b79a2059f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=aarnt
+_githubrepo=octopi
+_gitcommit=a92868cbb3df8ca87380800bf29827482baed18b
+
+pkgname=octopi-notifier-qt5-dev
+pkgver=0.14.0.r2.a92868c
+pkgrel=1
+pkgdesc='Notifier for Octopi using Qt5 libs'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+license=('GPL2')
+depends=('octopi-dev')
+makedepends=('git' 'qt5-tools')
+provides=('octopi-notifier')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_githubrepo}"
+ msg "Building octopi-notifier..."
+ cd notifier
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro
+ make
+}
+
+package() {
+ cd "${_githubrepo}"
+ cd notifier
+ make INSTALL_ROOT="${pkgdir}" install
+}