summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpappy2018-06-20 19:40:53 +0300
committerpappy2018-06-20 19:40:53 +0300
commit26f52bef4e9e70ef8c305450fa13641fc4212b05 (patch)
tree5c3879768ac3e8ceb5fbac37385a386037980d6c
parent5c9e6b1df84ca5363d9c025494726d8fa50938ff (diff)
downloadaur-26f52bef4e9e70ef8c305450fa13641fc4212b05.tar.gz
more system dependencies
-rw-r--r--.SRCINFO44
-rw-r--r--0020-click.patch12
-rw-r--r--PKGBUILD59
-rwxr-xr-xoctoprint.install10
4 files changed, 80 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb0c016956ba..584f846dad62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octoprint
pkgdesc = Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)
pkgver = 1.3.8
- pkgrel = 6
+ pkgrel = 7
url = http://octoprint.org/
install = octoprint.install
arch = x86_64
@@ -9,34 +9,38 @@ pkgbase = octoprint
arch = armv7h
license = AGPL3
makedepends = python2-virtualenv
- depends = python2-babel
depends = python2-argh
- depends = python2-frozendict
- depends = python2-regex
+ depends = python2-babel
+ depends = python2-backports.ssl_match_hostname
depends = python2-blinker
- depends = python2-wrapt
- depends = python2-requests
- depends = python2-markupsafe
- depends = python2-markdown
- depends = python2-pyserial
- depends = python2-pkginfo
- depends = python2-pathtools
- depends = python2-feedparser
- depends = python2-itsdangerous
depends = python2-certifi
- depends = python2-backports.ssl_match_hostname
depends = python2-chardet
+ depends = python2-click
+ depends = python2-feedparser
+ depends = python2-frozendict
depends = python2-idna
- depends = python2-six
- depends = python2-pyasn1
- depends = python2-urllib3
+ depends = python2-itsdangerous
+ depends = python2-markdown
+ depends = python2-markupsafe
depends = python2-netaddr
- depends = python2-speaklater
+ depends = python2-pathtools
+ depends = python2-pkginfo
+ depends = python2-pyasn1
+ depends = python2-pyserial
depends = python2-pytz
+ depends = python2-regex
+ depends = python2-requests
+ depends = python2-sarge
+ depends = python2-six
+ depends = python2-speaklater
+ depends = python2-urllib3
depends = python2-watchdog
+ depends = python2-wrapt
optdepends = ffmpeg: timelapse support
- optdepends = motion: motion detector which grabs images from video4linux devices and/or from webcams
+ optdepends = curaengine: fast and robust engine for processing 3D models
optdepends = mjpg-streamer: stream images from webcam
+ optdepends = motion: motion detector which grabs images from video4linux devices and/or from webcams
+ optdepends = python2-pybonjour: interface to Apple Bonjour and compatible DNS-SD libraries
provides = octoprint
conflicts = octoprint-venv
backup = etc/conf.d/octoprint
@@ -46,12 +50,14 @@ pkgbase = octoprint
source = octoprint-serve
source = octoprint.conf
source = 0010-pkginfo.patch
+ source = 0020-click.patch
sha256sums = ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad
sha256sums = bd9b7f989aefb02da1ac414f306861f21f084d886f0283eea11516482b407d65
sha256sums = 231685e84b0241a466766c766f8d3ba31efda3238f19e9adedea380e7b861737
sha256sums = 08e6ff10fb7f61c40e5770b67e8f7201d02d82d3bd46c5441a7f2b0435fbe9c2
sha256sums = 02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5
sha256sums = 735644dcd6a26eb02cefe1727d41d91c4a1dcb53d0b8a1876fe3fa9abe04eba2
+ sha256sums = a3e7a9d816d16c878bb893c1c34815c1f2ecdb9c568a0ef3d8be7dfaa2d12cf2
pkgname = octoprint
diff --git a/0020-click.patch b/0020-click.patch
new file mode 100644
index 000000000000..fb6022632c06
--- /dev/null
+++ b/0020-click.patch
@@ -0,0 +1,12 @@
+diff -ru OctoPrint-1.3.8-orig/setup.py OctoPrint-1.3.8/setup.py
+--- OctoPrint-1.3.8-orig/setup.py 2018-06-20 18:15:15.134173657 +0300
++++ OctoPrint-1.3.8/setup.py 2018-06-20 18:23:01.361656368 +0300
+@@ -42,7 +42,7 @@
+ "semantic_version>=2.4.2,<2.5",
+ "psutil==5.4.3", # 5.4.4 introduced a breaking change concerning installing under non current
+ # setuptools versions. Pinning to 5.4.3 for now to work around this.
+- "Click>=6.2,<6.3",
++ "Click>=6.2,<6.8",
+ "awesome-slugify>=1.6.5,<1.7",
+ "feedparser>=5.2.1,<5.3",
+ "chainmap>=1.0.2,<1.1",
diff --git a/PKGBUILD b/PKGBUILD
index 37c163f6b338..9bdc15511c3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,40 +4,46 @@ _pkgname=OctoPrint
pkgname=octoprint
# c55c568bbddf5112facf6aa3a173d500936b6cbf
pkgver=1.3.8
-pkgrel=6
+pkgrel=7
pkgdesc="Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)"
arch=(x86_64 armv6h armv7h)
url="http://octoprint.org/"
license=('AGPL3')
-depends=(python2-babel
+depends=(
python2-argh
- python2-frozendict
- python2-regex
+ python2-babel
+ python2-backports.ssl_match_hostname
python2-blinker
- python2-wrapt
- python2-requests
- python2-markupsafe
- python2-markdown
- python2-pyserial
- python2-pkginfo
- python2-pathtools
- python2-feedparser
- python2-itsdangerous
python2-certifi
- python2-backports.ssl_match_hostname
python2-chardet
+ python2-click
+ python2-feedparser
+ python2-frozendict
python2-idna
- python2-six
- python2-pyasn1
- python2-urllib3
+ python2-itsdangerous
+ python2-markdown
+ python2-markupsafe
python2-netaddr
- python2-speaklater
+ python2-pathtools
+ python2-pkginfo
+ python2-pyasn1
+ python2-pyserial
python2-pytz
- python2-watchdog)
+ python2-regex
+ python2-requests
+ python2-sarge
+ python2-six
+ python2-speaklater
+ python2-urllib3
+ python2-watchdog
+ python2-wrapt
+ )
makedepends=('python2-virtualenv')
optdepends=('ffmpeg: timelapse support'
- 'motion: motion detector which grabs images from video4linux devices and/or from webcams'
+ 'curaengine: fast and robust engine for processing 3D models'
'mjpg-streamer: stream images from webcam'
+ 'motion: motion detector which grabs images from video4linux devices and/or from webcams'
+ 'python2-pybonjour: interface to Apple Bonjour and compatible DNS-SD libraries'
)
provides=(octoprint)
conflicts=('octoprint-venv')
@@ -51,6 +57,7 @@ source=($pkgname-$pkgver.tar.gz::https://github.com/foosel/$_pkgname/archive/$pk
octoprint.conf
0010-pkginfo.patch
+ 0020-click.patch
)
sha256sums=('ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad'
@@ -58,7 +65,8 @@ sha256sums=('ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad'
'231685e84b0241a466766c766f8d3ba31efda3238f19e9adedea380e7b861737'
'08e6ff10fb7f61c40e5770b67e8f7201d02d82d3bd46c5441a7f2b0435fbe9c2'
'02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5'
- '735644dcd6a26eb02cefe1727d41d91c4a1dcb53d0b8a1876fe3fa9abe04eba2')
+ '735644dcd6a26eb02cefe1727d41d91c4a1dcb53d0b8a1876fe3fa9abe04eba2'
+ 'a3e7a9d816d16c878bb893c1c34815c1f2ecdb9c568a0ef3d8be7dfaa2d12cf2')
prepare()
{
@@ -66,20 +74,23 @@ prepare()
for s in ${source[@]}; do
case $s in
- *.patch) patch -p1 -i ${srcdir}/$s
+ *.patch) echo -n Applying patch $s...
+ patch -s -p1 -i ${srcdir}/$s
+ echo ' done'
;;
esac
done
}
package() {
- virtualenv2 --system-site-packages $pkgdir/usr/lib/$pkgname
+ virtualenv2 --system-site-packages --no-wheel $pkgdir/usr/lib/$pkgname
pushd $_pkgname-$pkgver
$pkgdir/usr/lib/$pkgname/bin/pip install --install-option '--optimize=1' .
+ $pkgdir/usr/lib/$pkgname/bin/pip uninstall -y setuptools
popd
-# find $pkgdir/usr/lib/$pkgname -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;
+ find $pkgdir/usr/lib/$pkgname/bin -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;
install -Dm644 octoprint.sysusers $pkgdir/usr/lib/sysusers.d/octoprint.conf
install -Dm644 octoprint.service $pkgdir/usr/lib/systemd/system/octoprint.service
diff --git a/octoprint.install b/octoprint.install
index 4d1ed2998900..66363a4fea9f 100755
--- a/octoprint.install
+++ b/octoprint.install
@@ -1,9 +1,9 @@
post_install()
{
- systemd-sysusers
+ systemd-sysusers
mkdir -p /var/lib/octoprint
- chown -R octoprint:octoprint /var/lib/octoprint
+ chown -R octoprint:octoprint /var/lib/octoprint /usr/lib/octoprint/lib/python2.7/site-packages
echo "To start octoprint, run: systemctl start octoprint"
echo "To enable octoprint at boot, run: systemctl enable octoprint"
@@ -20,3 +20,9 @@ pre_remove()
systemctl disable octoprint
}
+post_remove()
+{
+ # cleanup
+ rm -rf /usr/lib/octoprint
+}
+