summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpappy2018-06-19 18:43:36 +0300
committerpappy2018-06-19 18:45:19 +0300
commitc5e2b88d80b34a5bc8c7fa19cd366466224300bf (patch)
tree361fba7edff2f61c81fd3ce375699ddeaaf0887f
parented8b3e55e7677a232de2c8fc37c87e2ff328b44a (diff)
downloadaur-c5e2b88d80b34a5bc8c7fa19cd366466224300bf.tar.gz
see description
- use system pkginfo - corrected typo in install script - removed *all* $pkgdir references
-rw-r--r--.SRCINFO5
-rw-r--r--0010-pkginfo.patch12
-rw-r--r--PKGBUILD23
-rwxr-xr-xoctoprint.install2
4 files changed, 37 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c30d6177766e..bb0c016956ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octoprint
pkgdesc = Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)
pkgver = 1.3.8
- pkgrel = 5
+ pkgrel = 6
url = http://octoprint.org/
install = octoprint.install
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = octoprint
depends = python2-markupsafe
depends = python2-markdown
depends = python2-pyserial
+ depends = python2-pkginfo
depends = python2-pathtools
depends = python2-feedparser
depends = python2-itsdangerous
@@ -44,11 +45,13 @@ pkgbase = octoprint
source = octoprint.service
source = octoprint-serve
source = octoprint.conf
+ source = 0010-pkginfo.patch
sha256sums = ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad
sha256sums = bd9b7f989aefb02da1ac414f306861f21f084d886f0283eea11516482b407d65
sha256sums = 231685e84b0241a466766c766f8d3ba31efda3238f19e9adedea380e7b861737
sha256sums = 08e6ff10fb7f61c40e5770b67e8f7201d02d82d3bd46c5441a7f2b0435fbe9c2
sha256sums = 02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5
+ sha256sums = 735644dcd6a26eb02cefe1727d41d91c4a1dcb53d0b8a1876fe3fa9abe04eba2
pkgname = octoprint
diff --git a/0010-pkginfo.patch b/0010-pkginfo.patch
new file mode 100644
index 000000000000..2a191fab9931
--- /dev/null
+++ b/0010-pkginfo.patch
@@ -0,0 +1,12 @@
+diff -ru OctoPrint-1.3.8-orig/setup.py OctoPrint-1.3.8/setup.py
+--- OctoPrint-1.3.8-orig/setup.py 2018-04-13 17:22:44.000000000 +0300
++++ OctoPrint-1.3.8/setup.py 2018-06-19 16:39:03.394773021 +0300
+@@ -37,7 +37,7 @@
+ "netifaces>=0.10,<0.11",
+ "pylru>=1.0.9,<1.1",
+ "rsa>=3.2,<3.3",
+- "pkginfo>=1.2.1,<1.3",
++ "pkginfo>=1.2.1",
+ "requests>=2.18.4,<3",
+ "semantic_version>=2.4.2,<2.5",
+ "psutil==5.4.3", # 5.4.4 introduced a breaking change concerning installing under non current
diff --git a/PKGBUILD b/PKGBUILD
index feb079481735..d700a2afe871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=OctoPrint
pkgname=octoprint
# c55c568bbddf5112facf6aa3a173d500936b6cbf
pkgver=1.3.8
-pkgrel=5
+pkgrel=6
pkgdesc="Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)"
arch=(x86_64 armv6h armv7h)
url="http://octoprint.org/"
@@ -19,6 +19,7 @@ depends=(python2-babel
python2-markupsafe
python2-markdown
python2-pyserial
+ python2-pkginfo
python2-pathtools
python2-feedparser
python2-itsdangerous
@@ -43,17 +44,33 @@ conflicts=('octoprint-venv')
install=octoprint.install
backup=(etc/conf.d/octoprint)
source=($pkgname-$pkgver.tar.gz::https://github.com/foosel/$_pkgname/archive/$pkgver.tar.gz
+
octoprint.sysusers
octoprint.service
octoprint-serve
octoprint.conf
+
+ 0010-pkginfo.patch
)
sha256sums=('ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad'
'bd9b7f989aefb02da1ac414f306861f21f084d886f0283eea11516482b407d65'
'231685e84b0241a466766c766f8d3ba31efda3238f19e9adedea380e7b861737'
'08e6ff10fb7f61c40e5770b67e8f7201d02d82d3bd46c5441a7f2b0435fbe9c2'
- '02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5')
+ '02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5'
+ '735644dcd6a26eb02cefe1727d41d91c4a1dcb53d0b8a1876fe3fa9abe04eba2')
+
+prepare()
+{
+ cd $_pkgname-$pkgver
+
+ for s in ${source[@]}; do
+ case $s in
+ *.patch) patch -p1 -i ${srcdir}/$s
+ ;;
+ esac
+ done
+}
package() {
virtualenv2 --system-site-packages $pkgdir/usr/lib/$pkgname
@@ -62,7 +79,7 @@ package() {
$pkgdir/usr/lib/$pkgname/bin/pip install .
popd
- find $pkgdir/usr/lib/$pkgname/bin -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::" {} \;
+ find $pkgdir/usr/lib/$pkgname -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;
install -Dm644 octoprint.sysusers $pkgdir/usr/lib/sysusers.d/octoprint.conf
install -Dm644 octoprint.service $pkgdir/usr/lib/systemd/system/octoprint.service
diff --git a/octoprint.install b/octoprint.install
index 5c6141411ab3..4d1ed2998900 100755
--- a/octoprint.install
+++ b/octoprint.install
@@ -11,7 +11,7 @@ post_install()
post_upgrade()
{
- systemct daemon-reload
+ systemctl daemon-reload
}
pre_remove()