summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpappy2021-08-09 00:56:59 +0200
committerpappy2021-08-09 00:57:38 +0200
commitcbe4d28dc1e21fce77d094a70635777d0319738a (patch)
tree065ac4a73a17e68a15f87ef2e41a183cc677e52f
parentf18a4266454097870740395281ae591e378028f7 (diff)
downloadaur-cbe4d28dc1e21fce77d094a70635777d0319738a.tar.gz
more system dependencies
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c85b6deda8..679cf4970b46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octoprint
pkgdesc = The snappy web interface for your 3D printer on Arch Linux
pkgver = 1.6.1
- pkgrel = 3
+ pkgrel = 4
url = http://octoprint.org/
install = octoprint.install
arch = any
@@ -23,6 +23,8 @@ pkgbase = octoprint
depends = python-filetype
depends = python-blinker
depends = python-babel
+ depends = python-cachelib
+ depends = python-pylru
optdepends = ffmpeg: timelapse support
optdepends = curaengine: fast and robust engine for processing 3D models
optdepends = mjpg-streamer: stream images from webcam
diff --git a/PKGBUILD b/PKGBUILD
index 65a348a1bc6b..6cdccd9e3bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=octoprint
pkgver=1.6.1
-pkgrel=3
+pkgrel=4
pkgdesc="The snappy web interface for your 3D printer on Arch Linux"
arch=(any)
url="http://octoprint.org/"
@@ -22,9 +22,12 @@ depends=(
python-wrapt
python-filetype
python-blinker
-
python-babel
- )
+
+ # aur
+ python-cachelib
+ python-pylru
+)
makedepends=('python-virtualenv' 'rust')
optdepends=('ffmpeg: timelapse support'
'curaengine: fast and robust engine for processing 3D models'
@@ -63,10 +66,11 @@ prepare()
}
package() {
- virtualenv --system-site-packages --no-setuptools --no-wheel $pkgdir/usr/lib/$pkgname
+ python -m venv --system-site-packages --symlinks $pkgdir/usr/lib/$pkgname
+ source $pkgdir/usr/lib/$pkgname/bin/activate
pushd $srcdir/OctoPrint-${pkgver}
- $pkgdir/usr/lib/$pkgname/bin/pip --no-cache-dir install --install-option '--optimize=1' .
+ pip --use-feature=in-tree-build --no-cache-dir install --install-option '--optimize=1' .
popd
find $pkgdir/usr/lib/$pkgname/bin -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;