summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpappy2018-06-17 19:16:54 +0300
committerpappy2018-06-17 20:36:43 +0300
commited8b3e55e7677a232de2c8fc37c87e2ff328b44a (patch)
treef0fcfdd63865e769d6b99d91928983dbc6672002
parentadaf10f4423f408f63cfb70a2fd7098b4f71a48b (diff)
downloadaur-ed8b3e55e7677a232de2c8fc37c87e2ff328b44a.tar.gz
use system python2 packages
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b051975f4ac..c30d6177766e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octoprint
pkgdesc = Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)
pkgver = 1.3.8
- pkgrel = 4
+ pkgrel = 5
url = http://octoprint.org/
install = octoprint.install
arch = x86_64
@@ -9,6 +9,30 @@ pkgbase = octoprint
arch = armv7h
license = AGPL3
makedepends = python2-virtualenv
+ depends = python2-babel
+ depends = python2-argh
+ depends = python2-frozendict
+ depends = python2-regex
+ depends = python2-blinker
+ depends = python2-wrapt
+ depends = python2-requests
+ depends = python2-markupsafe
+ depends = python2-markdown
+ depends = python2-pyserial
+ depends = python2-pathtools
+ depends = python2-feedparser
+ depends = python2-itsdangerous
+ depends = python2-certifi
+ depends = python2-backports.ssl_match_hostname
+ depends = python2-chardet
+ depends = python2-idna
+ depends = python2-six
+ depends = python2-pyasn1
+ depends = python2-urllib3
+ depends = python2-netaddr
+ depends = python2-speaklater
+ depends = python2-pytz
+ depends = python2-watchdog
optdepends = ffmpeg: timelapse support
optdepends = motion: motion detector which grabs images from video4linux devices and/or from webcams
optdepends = mjpg-streamer: stream images from webcam
diff --git a/PKGBUILD b/PKGBUILD
index dd38a7e67442..feb079481735 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: pappy <pappy _AT_ a s c e l i o n _DOT_ com>
-# Maintainer: Niklas <dev@n1klas.net>
-# Contributor: Yunhui Fu <yhfudev@gmail.com>
-# Contributor: Doug Richardson <dougie.richardson@gmail.com>
-# Contributor: feilen <feilen1000@gmail.com>
-# Contributor: Thermionix <thermionix@gmail.com>
_pkgname=OctoPrint
pkgname=octoprint
# c55c568bbddf5112facf6aa3a173d500936b6cbf
pkgver=1.3.8
-pkgrel=4
+pkgrel=5
pkgdesc="Responsive web interface for controlling a 3D printer (RepRap, Ultimaker, ...)"
arch=(x86_64 armv6h armv7h)
url="http://octoprint.org/"
license=('AGPL3')
+depends=(python2-babel
+ python2-argh
+ python2-frozendict
+ python2-regex
+ python2-blinker
+ python2-wrapt
+ python2-requests
+ python2-markupsafe
+ python2-markdown
+ python2-pyserial
+ python2-pathtools
+ python2-feedparser
+ python2-itsdangerous
+ python2-certifi
+ python2-backports.ssl_match_hostname
+ python2-chardet
+ python2-idna
+ python2-six
+ python2-pyasn1
+ python2-urllib3
+ python2-netaddr
+ python2-speaklater
+ python2-pytz
+ python2-watchdog)
makedepends=('python2-virtualenv')
optdepends=('ffmpeg: timelapse support'
'motion: motion detector which grabs images from video4linux devices and/or from webcams'
@@ -37,7 +56,7 @@ sha256sums=('ca1bc5352ef20778722a6b2aedef4c8dbe28d0d82c2526f84f3db07245a01aad'
'02be5d5a18febe215809882d96f068092c4474abb4e76d82e4450b860a4e9ef5')
package() {
- virtualenv2 $pkgdir/usr/lib/$pkgname
+ virtualenv2 --system-site-packages $pkgdir/usr/lib/$pkgname
pushd $_pkgname-$pkgver
$pkgdir/usr/lib/$pkgname/bin/pip install .