summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-11-27 18:05:26 +0200
committerAnton Kudelin2021-11-27 18:05:26 +0200
commit2aef85ef939b9dc009d4ee9f395e6dd23ddccfb3 (patch)
tree6b19589200167b08206300aeba5eb4a129410461
parent5800b7a9fa4f17cf3887bd417fa628ffa924fa08 (diff)
downloadaur-2aef85ef939b9dc009d4ee9f395e6dd23ddccfb3.tar.gz
updpkg: 11.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD64
2 files changed, 44 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a03ec8cd2a..832e947d9d7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octopus
pkgdesc = Real-space Time-Dependent Density Functional Theory code
- pkgver = 9.2
- pkgrel = 3
+ pkgver = 11.3
+ pkgrel = 1
url = https://octopus-code.org
arch = x86_64
license = LGPL
@@ -13,8 +13,12 @@ pkgbase = octopus
depends = libxc
depends = libvdwxc
depends = netcdf-fortran
- source = https://gitlab.com/octopus-code/octopus/-/archive/9.2/octopus-9.2.tar.bz2
- sha256sums = 20bed6d1450205373e1500a38110d911bca4f38aa154c26ed877821d9eae0d1e
+ depends = parmetis
+ depends = nlopt
+ depends = cgal
+ depends = clfft
+ depends = clblas
+ source = https://octopus-code.org/down.php?file=11.3/octopus-11.3.tar.gz
+ sha256sums = 0c98417071b5e38ba6cbdd409adf917837c387a010e321c0a7f94d9bd9478930
pkgname = octopus
-
diff --git a/PKGBUILD b/PKGBUILD
index a5afb057998d..8241e4de0074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,60 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
# Contributor: Scott Tincman <sctincman at gmail dot com>
pkgname=octopus
-pkgver=9.2
-pkgrel=3
+pkgver=11.3
+pkgrel=1
pkgdesc="Real-space Time-Dependent Density Functional Theory code"
arch=('x86_64')
url="https://octopus-code.org"
license=('LGPL')
-depends=('elpa' 'gd' 'gsl' 'libxc' 'libvdwxc' 'netcdf-fortran')
+depends=('elpa' 'gd' 'gsl' 'libxc' 'libvdwxc' 'netcdf-fortran' 'parmetis'
+ 'nlopt' 'cgal' 'clfft' 'clblas')
makedepends=('gcc-fortran')
checkdepends=('procps-ng')
-source=("https://gitlab.com/octopus-code/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('20bed6d1450205373e1500a38110d911bca4f38aa154c26ed877821d9eae0d1e')
+source=("$url/down.php?file=$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('0c98417071b5e38ba6cbdd409adf917837c387a010e321c0a7f94d9bd9478930')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- autoreconf -if
+ mkdir -p "$srcdir/build"
+ autoreconf -if "$srcdir/$pkgname-$pkgver"
export _elpaver=$( ls /usr/include | grep elpa | sed 's/elpa_openmp-//g' )
export OPTFLAGS="-O3 -march=native"
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure \
- --prefix=/usr \
- --enable-mpi \
- --enable-vectors \
- --with-scalapack="-lscalapack" \
- --with-blacs="-lscalapack" \
- --with-elpa-prefix=/usr \
- FCFLAGS_ELPA="-I/usr/include/elpa_openmp-$_elpaver/modules" \
- LIBS_ELPA="-lelpa_openmp" \
- CFLAGS="$OPTFLAGS" \
- CXXFLAGS="$OPTFLAGS" \
- FCFLAGS="$OPTFLAGS -fallow-argument-mismatch -fallow-invalid-boz"
+ cd "$srcdir/build"
+ ../$pkgname-$pkgver/configure \
+ --prefix=/usr \
+ --enable-mpi \
+ --enable-vectors \
+ --with-scalapack="-lscalapack" \
+ --with-blacs="-lscalapack" \
+ --with-elpa-prefix=/usr \
+ --with-cgal=/usr \
+ --with-clfft-prefix=/usr \
+ --with-clblas-prefix=/usr \
+ FCFLAGS_ELPA="-I/usr/include/elpa_openmp-$_elpaver/modules" \
+ LIBS_ELPA="-lelpa_openmp" \
+ CFLAGS="$OPTFLAGS" \
+ CXXFLAGS="$OPTFLAGS" \
+ FCFLAGS="$OPTFLAGS -fallow-argument-mismatch -fallow-invalid-boz"
make
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
- for t in testsuite/photo_electron/*.test
- do
- sed -i "s/Yes/No/g" $t
- done
- sed -i "s/Yes/No/g" testsuite/finite_systems_3d/14-fullerene_unpacked.test
- make check
+ cd "$srcdir/$pkgname-$pkgver/testsuite"
+ sed -i "s/Yes/No/g" \
+ finite_systems_1d/02-neon_mpi.test \
+ functionals/18-mgga.test \
+ real_time/01-propagators.test \
+ real_time/06-caetrs.test
+
+ cd "../../build"
+ make check-short
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/build"
make DESTDIR="$pkgdir" install
}