summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2021-04-21 22:14:43 +0200
committerMikael Eriksson2021-04-21 22:14:43 +0200
commit39c7f30dafd47954b5eed1e4fd27a791ad5ea105 (patch)
tree2e3776f139bb4ec558cce7dc6962eeb2d603ccea
parentf30d1a53f9bfdd491c7b69a2038fd8a8dc0e6f53 (diff)
downloadaur-39c7f30dafd47954b5eed1e4fd27a791ad5ea105.tar.gz
Remove unused patches. Thanks dpflug for reminding me
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Fix-WAD-path.patch14
-rw-r--r--PKGBUILD4
-rw-r--r--fix-cxxflags.diff12
4 files changed, 1 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 135fcb3c6885..2dbda654cead 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,6 @@ pkgbase = odamex
optdepends = timidity++: Required for music
source = http://downloads.sourceforge.net/odamex/odamex-src-0.9.0.tar.bz2
sha256sums = c18733312a81224ffe238d6e8f80291ec0f5cc8c967cef0ef1908df551dfd979
- sha256sums = c4ce4072515c7dbfe65d1829a317d21b5f1091e04997761cdfee345a60141638
- sha256sums = 0541328408d71dfcd7cdf866497f9cc2c7f10780986d2fea5743f5df584d923a
pkgname = odamex
diff --git a/0001-Fix-WAD-path.patch b/0001-Fix-WAD-path.patch
deleted file mode 100644
index 12b485ac80a4..000000000000
--- a/0001-Fix-WAD-path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --unified --recursive --text odamex-src-0.8.0/common/d_main.cpp "odamex-src-0.8.0 diff/common/d_main.cpp"
---- odamex-src-0.8.0/common/d_main.cpp 2019-01-23 04:01:47.000000000 +0100
-+++ "odamex-src-0.8.0 diff/common/d_main.cpp" 2019-03-07 22:31:46.807985980 +0100
-@@ -499,6 +499,8 @@
- dirs.push_back(progdir);
-
- D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
-+ D_AddSearchDir(dirs, "/usr/share/odamex", separator);
-+ D_AddSearchDir(dirs, "/usr/share/doom", separator);
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
-
- VERSION_CONTROL (d_main_cpp, "$Id: cc97705a3130a984ef22d249de74a1dc64ba33a8 $")
diff --git a/PKGBUILD b/PKGBUILD
index 7376adae44d7..6a511a47b439 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,7 @@ depends=('sdl2_mixer' 'portmidi' 'wxgtk2' 'miniupnpc')
makedepends=('cmake')
optdepends=('timidity++: Required for music')
source=("http://downloads.sourceforge.net/odamex/odamex-src-${pkgver}.tar.bz2")
-sha256sums=('c18733312a81224ffe238d6e8f80291ec0f5cc8c967cef0ef1908df551dfd979'
- 'c4ce4072515c7dbfe65d1829a317d21b5f1091e04997761cdfee345a60141638'
- '0541328408d71dfcd7cdf866497f9cc2c7f10780986d2fea5743f5df584d923a')
+sha256sums=('c18733312a81224ffe238d6e8f80291ec0f5cc8c967cef0ef1908df551dfd979')
prepare() {
cd $pkgname-src-$pkgver
diff --git a/fix-cxxflags.diff b/fix-cxxflags.diff
deleted file mode 100644
index 16630c777703..000000000000
--- a/fix-cxxflags.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur odamex-src-0.8.3.org/CMakeLists.txt odamex-src-0.8.3/CMakeLists.txt
---- odamex-src-0.8.3.org/CMakeLists.txt 2020-05-10 05:29:36.000000000 +0200
-+++ odamex-src-0.8.3/CMakeLists.txt 2020-06-13 22:56:47.027614254 +0200
-@@ -28,7 +28,7 @@
- set(PROJECT_COPYRIGHT "2006-2020")
-
- # Use C++ 98/03 for all targets
--set(CMAKE_CXX_STANDARD 98)
-+set(CMAKE_CXX_STANDARD 11)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
-
- # identify the target CPU