summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2020-06-13 23:11:38 +0200
committerMikael Eriksson2020-06-13 23:11:38 +0200
commit42b79d77a598cb023660e3418f13910f366343d0 (patch)
treecdd781ead8e74d8bacdb51242110183aa2b2bb1b
parent2aef5dce7b86b647e91d65c51ab66675bffe3c4a (diff)
downloadaur-42b79d77a598cb023660e3418f13910f366343d0.tar.gz
0.8.3-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rw-r--r--fix-cxxflags.diff12
3 files changed, 27 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c4aaa994ff9..e0f16c5c7cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = odamex
pkgdesc = A free client/server multiplayer engine for the classic FPS Doom.
- pkgver = 0.8.1
+ pkgver = 0.8.3
pkgrel = 1
url = http://odamex.net/
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- depends = sdl_mixer>=1.2.6
+ depends = sdl2_mixer
+ depends = portmidi
depends = wxgtk
depends = miniupnpc
optdepends = timidity++: Required for music
- source = http://downloads.sourceforge.net/odamex/odamex-src-0.8.1.tar.gz
+ source = http://downloads.sourceforge.net/odamex/odamex-src-0.8.3.tar.gz
source = 0001-Fix-WAD-path.patch
- sha256sums = 31704a45eae3a833dcc0c4c840444cda0ba88a2fc9b6115b612e31a6dcc48bfb
+ source = fix-cxxflags.diff
+ sha256sums = 26e111bef9af14dd538e6424b6663b24e97eab60fda8c76e2398d575d03b0839
sha256sums = c4ce4072515c7dbfe65d1829a317d21b5f1091e04997761cdfee345a60141638
+ sha256sums = 0541328408d71dfcd7cdf866497f9cc2c7f10780986d2fea5743f5df584d923a
pkgname = odamex
diff --git a/PKGBUILD b/PKGBUILD
index d0cd33b1789b..6b46ff7a953b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,26 @@
# Contributor: Curtis Smith <kman922002@gmail.com>
pkgname=odamex
-pkgver=0.8.1
+pkgver=0.8.3
pkgrel=1
pkgdesc='A free client/server multiplayer engine for the classic FPS Doom.'
arch=('i686' 'x86_64')
url='http://odamex.net/'
license=('GPL')
-depends=('sdl_mixer>=1.2.6' 'wxgtk' 'miniupnpc')
+depends=('sdl2_mixer' 'portmidi' 'wxgtk' 'miniupnpc')
makedepends=('cmake')
optdepends=('timidity++: Required for music')
source=("http://downloads.sourceforge.net/odamex/odamex-src-${pkgver}.tar.gz"
- 0001-Fix-WAD-path.patch)
-sha256sums=('31704a45eae3a833dcc0c4c840444cda0ba88a2fc9b6115b612e31a6dcc48bfb'
- 'c4ce4072515c7dbfe65d1829a317d21b5f1091e04997761cdfee345a60141638')
+ 0001-Fix-WAD-path.patch
+ fix-cxxflags.diff)
+sha256sums=('26e111bef9af14dd538e6424b6663b24e97eab60fda8c76e2398d575d03b0839'
+ 'c4ce4072515c7dbfe65d1829a317d21b5f1091e04997761cdfee345a60141638'
+ '0541328408d71dfcd7cdf866497f9cc2c7f10780986d2fea5743f5df584d923a')
prepare() {
cd $pkgname-src-$pkgver
patch --forward --strip=1 --input="${srcdir}/0001-Fix-WAD-path.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix-cxxflags.diff"
}
build() {
diff --git a/fix-cxxflags.diff b/fix-cxxflags.diff
new file mode 100644
index 000000000000..16630c777703
--- /dev/null
+++ b/fix-cxxflags.diff
@@ -0,0 +1,12 @@
+diff -aur odamex-src-0.8.3.org/CMakeLists.txt odamex-src-0.8.3/CMakeLists.txt
+--- odamex-src-0.8.3.org/CMakeLists.txt 2020-05-10 05:29:36.000000000 +0200
++++ odamex-src-0.8.3/CMakeLists.txt 2020-06-13 22:56:47.027614254 +0200
+@@ -28,7 +28,7 @@
+ set(PROJECT_COPYRIGHT "2006-2020")
+
+ # Use C++ 98/03 for all targets
+-set(CMAKE_CXX_STANDARD 98)
++set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+ # identify the target CPU