summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-01-09 23:24:47 +0100
committerjose17112016-01-09 23:24:47 +0100
commit20c5950fcc0e5694fad2efc9d47f3cac400d99f7 (patch)
tree178227ef7b3a1bf2699d5f5b56ce041fa305aeea
downloadaur-20c5950fcc0e5694fad2efc9d47f3cac400d99f7.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bcc207a4e26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 22:24:39 UTC 2016
+pkgbase = ode-011
+ pkgdesc = An open source, high performance library for simulating rigid body dynamics
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = http://www.ode.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ license = BSD
+ provides = ode
+ conflicts = ode
+ options = !libtool
+ source = http://downloads.sourceforge.net/opende/ode-0.11.1.tar.bz2
+ md5sums = 712579afabc2a15aa56e399f76171477
+
+pkgname = ode-011
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca940a987691
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: 404
+# Contributor carstene1ns <arch carsten-teibes de>
+# Contributor: Heine Laursen <zann at gmail dot com>
+# Contributor: Christoph Zeiler <rabyteNOSPAM_at_gmx.dot.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Adam Griffiths <adam_griffithsAATTdart.net.au>
+
+pkgname=ode-011
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="An open source, high performance library for simulating rigid body dynamics"
+arch=('i686' 'x86_64')
+url="http://www.ode.org"
+license=('LGPL' 'BSD')
+options=('!libtool')
+provides=('ode')
+conflicts=('ode')
+source=("http://downloads.sourceforge.net/opende/ode-$pkgver.tar.bz2")
+md5sums=('712579afabc2a15aa56e399f76171477')
+
+build() {
+ cd ode-$pkgver
+
+ LIBS="$LIBS -lX11" ./configure --prefix=/usr --enable-shared \
+ --enable-release --disable-asserts --with-trimesh=opcode
+
+ make
+}
+
+package() {
+ cd ode-$pkgver
+
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}