summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-09-12 11:06:39 +0200
committerFabioLolix2021-09-12 11:06:39 +0200
commit4cd7de379379a4790348737ff3f3a22e6bf157dc (patch)
tree4ee78530e033221f00ef1d95500d6a3afba98e0c
parent063655966efd0f8394eb91ff9c14294e2fd7a033 (diff)
downloadaur-4cd7de379379a4790348737ff3f3a22e6bf157dc.tar.gz
revision
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb0e7f501a82..90304da55e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = odin-git
pkgdesc = compiler for the odin programming language
- pkgver = r973.0134c38
- pkgrel = 2
+ pkgver = r4558.82736370
+ pkgrel = 1
url = http://github.com/odin-lang/odin
arch = x86_64
license = BSD
- makedepends = clang
- makedepends = llvm
makedepends = git
+ makedepends = clang
+ makedepends = llvm11
+ depends = glibc
+ depends = ncurses
provides = odin
conflicts = odin
source = git+https://github.com/odin-lang/odin.git
sha256sums = SKIP
pkgname = odin-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 74dee7f72b4f..fb17b658277a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: J.D. Broberg <jdbroberg72 at gmail dot com>
+# Maintainer: Hannah
+# Maintainer: FabioLolix
+# Contributor: J.D. Broberg <jdbroberg72 at gmail dot com>
pkgname=odin-git
_pkgname=odin
-pkgver=r973.0134c38
-pkgrel=2
+pkgver=r4558.82736370
+pkgrel=1
pkgdesc="compiler for the odin programming language"
-arch=('x86_64')
+arch=(x86_64)
url="http://github.com/odin-lang/odin"
-license=('BSD')
-source=('git+https://github.com/odin-lang/odin.git')
-makedepends=('clang' 'llvm' 'git')
-conflicts=('odin')
-provides=('odin')
+license=(BSD)
+depends=(glibc ncurses)
+makedepends=(git clang llvm11)
+provides=(odin)
+conflicts=(odin)
+source=("git+https://github.com/odin-lang/odin.git")
sha256sums=('SKIP')
pkgver() {
@@ -21,7 +24,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- make debug
+ make release
}
package() {
@@ -35,5 +38,5 @@ package() {
cp -av "./core" "${pkgdir}/opt/${_pkgname}"
- install -Dm644 "./LICENSE" "${pkgdir}/opt/${_pkgname}/LICENSE"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}