summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-03-06 14:00:25 +0100
committerFabioLolix2022-03-06 14:00:25 +0100
commit79efd47fc9772db4ccd873703a57bcc351cb46db (patch)
tree44b6d4d7f2d8bc62f995033e30bf13b5704b1f09
parentce009c24fcd4818425f15c39aff8063a17b51896 (diff)
downloadaur-79efd47fc9772db4ccd873703a57bcc351cb46db.tar.gz
build with llvm13
-rw-r--r--.SRCINFO7
-rw-r--r--0001-use-llvm13.patch33
-rw-r--r--PKGBUILD12
3 files changed, 43 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e08b66c3430d..8bc2a6acb719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = odin-git
pkgdesc = A fast, concise, readable, pragmatic and open sourced programming language.
- pkgver = r4965.0bc3652f
+ pkgver = r5763.758d1e2a
pkgrel = 1
url = https://github.com/odin-lang/odin
arch = x86_64
@@ -9,12 +9,13 @@ pkgbase = odin-git
makedepends = clang
makedepends = llvm
depends = glibc
+ depends = llvm-libs
depends = ncurses
provides = odin
conflicts = odin
source = git+https://github.com/odin-lang/odin.git
- source = 0001-update-odin-to-use-llvm-12.patch
+ source = 0001-use-llvm13.patch
sha256sums = SKIP
- sha256sums = 950663559a9677db912babbc7372b16d41ba03d64d3ea0f39544680fce8a0a25
+ sha256sums = 4e0e571d4067975f0405564d7110d67092549a213a3012ff3a42f93efffda84f
pkgname = odin-git
diff --git a/0001-use-llvm13.patch b/0001-use-llvm13.patch
new file mode 100644
index 000000000000..7d1f28f22e6a
--- /dev/null
+++ b/0001-use-llvm13.patch
@@ -0,0 +1,33 @@
+From 5295e01a6b9b8e50d4ea2aa3f6fb015ad39c0371 Mon Sep 17 00:00:00 2001
+From: FabioLolix <fabio.loli@disroot.org>
+Date: Sun, 6 Mar 2022 13:51:29 +0100
+Subject: [PATCH] use llvm13
+
+---
+ Makefile | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ceff3c20..ef3dc59b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,11 +40,11 @@ ifeq ($(OS), Darwin)
+ LDFLAGS:=$(LDFLAGS) -lLLVM-C
+ endif
+ ifeq ($(OS), Linux)
+- LLVM_CONFIG=llvm-config-11
+- ifneq ($(shell which llvm-config-11 2>/dev/null),)
+- LLVM_CONFIG=llvm-config-11
+- else ifneq ($(shell which llvm-config-11-64 2>/dev/null),)
+- LLVM_CONFIG=llvm-config-11-64
++ LLVM_CONFIG=llvm-config
++ ifneq ($(shell which llvm-config 2>/dev/null),)
++ LLVM_CONFIG=llvm-config
++ else ifneq ($(shell which llvm-config-64 2>/dev/null),)
++ LLVM_CONFIG=llvm-config-64
+ else
+ ifeq ($(shell $(LLVM_CONFIG) --version | grep '^11\.'),)
+ $(error "Requirement: llvm-config must be version 11")
+--
+2.35.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 957649059483..7b0009a817e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
pkgname=odin-git
_pkgname=odin
-pkgver=r4965.0bc3652f
+pkgver=r5763.758d1e2a
pkgrel=1
pkgdesc="A fast, concise, readable, pragmatic and open sourced programming language."
arch=(x86_64)
url="https://github.com/odin-lang/odin"
license=(BSD)
-depends=(glibc ncurses)
+depends=(glibc llvm-libs ncurses)
makedepends=(git clang llvm)
provides=(odin)
conflicts=(odin)
source=("git+https://github.com/odin-lang/odin.git"
- "0001-update-odin-to-use-llvm-12.patch")
+ '0001-use-llvm13.patch')
-sha256sums=("SKIP"
- "950663559a9677db912babbc7372b16d41ba03d64d3ea0f39544680fce8a0a25")
+sha256sums=('SKIP'
+ '4e0e571d4067975f0405564d7110d67092549a213a3012ff3a42f93efffda84f')
pkgver() {
cd "${_pkgname}"
@@ -28,7 +28,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- patch --forward --strip=1 --input="${srcdir}/0001-update-odin-to-use-llvm-12.patch"
+ patch --forward --strip=1 --input="${srcdir}/0001-use-llvm13.patch"
sed -i "s/linux\/libraylib.a/system:raylib/g" "vendor/raylib/raylib.odin"
make release
}