summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyxel2021-11-01 00:33:56 -0400
committerpyxel2021-11-01 00:33:56 -0400
commit9af1d271e632783a23a61efe383969c8852e4dd4 (patch)
treeb503fe8626b215c531185be2341744530f2cd34a
parent58785e53d0914500da1dfa89df684e44843d771d (diff)
downloadaur-9af1d271e632783a23a61efe383969c8852e4dd4.tar.gz
update package to build with llvm 12
-rw-r--r--.SRCINFO10
-rw-r--r--0001-update-odin-to-use-llvm-12.patch (renamed from 0001-use-clang-llvm11-binaries-package-to-build-odin.patch)24
-rw-r--r--PKGBUILD10
3 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c8440e61b13..f737373e6fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = odin-git
pkgdesc = A fast, concise, readable, pragmatic and open sourced programming language.
- pkgver = r4802.3337d386
+ pkgver = r4965.0bc3652f
pkgrel = 1
url = https://github.com/odin-lang/odin
arch = x86_64
license = BSD
makedepends = git
- makedepends = clang+llvm-binaries
+ makedepends = clang
+ makedepends = llvm
+ makedepends = lld
depends = glibc
depends = ncurses
provides = odin
conflicts = odin
source = git+https://github.com/odin-lang/odin.git
- source = 0001-use-clang-llvm11-binaries-package-to-build-odin.patch
+ source = 0001-update-odin-to-use-llvm-12.patch
sha256sums = SKIP
- sha256sums = 3aebc01fa0852ca9d14364558d6461b6211d7729010f2858ee591e240599a2fd
+ sha256sums = 950663559a9677db912babbc7372b16d41ba03d64d3ea0f39544680fce8a0a25
pkgname = odin-git
diff --git a/0001-use-clang-llvm11-binaries-package-to-build-odin.patch b/0001-update-odin-to-use-llvm-12.patch
index 255099859e82..7d64116ed609 100644
--- a/0001-use-clang-llvm11-binaries-package-to-build-odin.patch
+++ b/0001-update-odin-to-use-llvm-12.patch
@@ -1,17 +1,17 @@
-From 7b1c32778d81539d410be7af791f4ca2a27099ee Mon Sep 17 00:00:00 2001
+From 45705c2ccdfe4af2a1cf6b238525111c0c84693f Mon Sep 17 00:00:00 2001
From: pyxel <imhxnna@gmail.com>
-Date: Sun, 12 Sep 2021 21:18:47 -0400
-Subject: [PATCH] use clang+llvm11-binaries package to build odin
+Date: Mon, 1 Nov 2021 00:32:54 -0400
+Subject: [PATCH] update odin to use llvm 12
---
- Makefile | 57 +++++++++++++++++++++++++++++---------------------------
- 1 file changed, 30 insertions(+), 27 deletions(-)
+ Makefile | 61 +++++++++++++++++++++++++++++---------------------------
+ 1 file changed, 32 insertions(+), 29 deletions(-)
diff --git a/Makefile b/Makefile
-index cdf4f0fc..eeb4e57e 100644
+index 23fb7be6..15d00655 100644
--- a/Makefile
+++ b/Makefile
-@@ -7,33 +7,36 @@ CC=clang
+@@ -7,35 +7,38 @@ CC=clang
OS=$(shell uname)
@@ -31,6 +31,8 @@ index cdf4f0fc..eeb4e57e 100644
- LLVM_CONFIG=llvm-config-11
- ifneq ($(shell which llvm-config-11 2>/dev/null),)
- LLVM_CONFIG=llvm-config-11
+- else ifneq ($(shell which llvm-config-11-64 2>/dev/null),)
+- LLVM_CONFIG=llvm-config-11-64
- else
- ifneq ($(shell llvm-config --version | grep '^11\.'),)
- LLVM_CONFIG=llvm-config
@@ -58,6 +60,8 @@ index cdf4f0fc..eeb4e57e 100644
+# LLVM_CONFIG=llvm-config-11
+# ifneq ($(shell which llvm-config-11 2>/dev/null),)
+# LLVM_CONFIG=llvm-config-11
++# else ifneq ($(shell which llvm-config-11-64 2>/dev/null),)
++# LLVM_CONFIG=llvm-config-11-64
+# else
+# ifneq ($(shell llvm-config --version | grep '^11\.'),)
+# LLVM_CONFIG=llvm-config
@@ -70,11 +74,11 @@ index cdf4f0fc..eeb4e57e 100644
+# LDFLAGS:=$(LDFLAGS) $(shell $(LLVM_CONFIG) --libs core native --system-libs)
+#endif
+
-+CFLAGS:=$(CFLAGS) $(shell /opt/clang+llvm11/bin/llvm-config 2>/dev/null --cxxflags)
-+LDFLAGS:=$(LDFLAGS) $(shell /opt/clang+llvm11/bin/llvm-config 2>/dev/null --libs --ldflags) -lz -ltinfo
++CFLAGS:=$(CFLAGS) $(shell llvm-config --cxxflags)
++LDFLAGS:=$(LDFLAGS) $(shell llvm-config --libs --ldflags) -lz -ltinfo
all: debug demo
--
-2.33.0
+2.33.1
diff --git a/PKGBUILD b/PKGBUILD
index 75d0bfcf6a0a..2ec1aeca88bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
pkgname=odin-git
_pkgname=odin
-pkgver=r4802.3337d386
+pkgver=r4965.0bc3652f
pkgrel=1
pkgdesc="A fast, concise, readable, pragmatic and open sourced programming language."
arch=(x86_64)
url="https://github.com/odin-lang/odin"
license=(BSD)
depends=(glibc ncurses)
-makedepends=(git clang+llvm-binaries)
+makedepends=(git clang llvm lld)
provides=(odin)
conflicts=(odin)
source=("git+https://github.com/odin-lang/odin.git"
- "0001-use-clang-llvm11-binaries-package-to-build-odin.patch")
+ "0001-update-odin-to-use-llvm-12.patch")
sha256sums=("SKIP"
- "3aebc01fa0852ca9d14364558d6461b6211d7729010f2858ee591e240599a2fd")
+ "950663559a9677db912babbc7372b16d41ba03d64d3ea0f39544680fce8a0a25")
pkgver() {
cd "${_pkgname}"
@@ -28,7 +28,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- patch --forward --strip=1 --input="${srcdir}/0001-use-clang-llvm11-binaries-package-to-build-odin.patch"
+ patch --forward --strip=1 --input="${srcdir}/0001-update-odin-to-use-llvm-12.patch"
make release
}