summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuhammad2023-04-13 06:07:33 +0100
committerMuhammad2023-04-13 06:07:33 +0100
commitaa636c9a94a4fa09358fe3642f565a323ed3093d (patch)
treea00d4dcb7a8cf5855b8309f3a9daef27d4b61542
downloadaur-aa636c9a94a4fa09358fe3642f565a323ed3093d.tar.gz
880
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a2bbfffd36d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = odinls
+ pkgdesc = ols: language server for Odin
+ pkgver = 880
+ pkgrel = 1
+ url = https://github.com/DanielGavin/ols
+ arch = x86_64
+ license = MIT
+ depends = odin
+ options = !lto
+ source = git+https://github.com/DanielGavin/ols
+ sha256sums = SKIP
+
+pkgname = odinls
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0e6936807ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: <tjmnkrajyej at gmail dot com>
+pkgname=odinls
+pkgver=880
+pkgrel=1
+pkgdesc='ols: language server for Odin'
+arch=(x86_64)
+url=https://github.com/DanielGavin/ols
+license=(MIT)
+depends=(odin)
+options=('!lto')
+source=(git+$url)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ols
+ git rev-list --count @
+}
+
+build() {
+ cd ols
+ ./build.sh
+}
+
+package() {
+ install -D ols/ols "$pkgdir/usr/bin/ols"
+}
+