summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2022-05-14 19:38:06 +0200
committerRobert Tari2022-05-14 19:38:06 +0200
commit70838a2d475590f82cf6b9b3ea3be5b767976cac (patch)
tree1f72785da7e1188366dc85ee01bc0b0be1bed426
parentcb47fb063474ee40a3e5b94c83dd3f35e7e410c0 (diff)
downloadaur-70838a2d475590f82cf6b9b3ea3be5b767976cac.tar.gz
Automatic update via tari.in
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD1
-rw-r--r--odio.install9
3 files changed, 11 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51b7dba618a8..7c95f3819ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = odio
pkgver = 22.5.8
pkgrel = 1
url = https://tari.in/www/software/odio
+ install = odio.install
arch = any
license = GPL3
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index d813023e60fb..f01762de0500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ pkgdesc="Audio compression tool for FLAC and Nero AAC"
arch=("any")
url="https://tari.in/www/software/${pkgname}"
license=("GPL3")
+install="${pkgname}.install"
depends=("gst-plugins-good" "gst-plugins-bad" "gst-plugins-ugly" "gst-libav" "python-beautifulsoup4" "python-psutil" "python-mutagen" "odio-edit" "neroaacenc-bin" "libodiosacd" "lsdvd")
makedepends=("python-setuptools" "python-polib")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tari01/${pkgname}/archive/${pkgver}.tar.gz")
diff --git a/odio.install b/odio.install
index 42db1224a247..a9324b78e802 100644
--- a/odio.install
+++ b/odio.install
@@ -5,6 +5,8 @@ post_install()
pycompile -p odio
fi
+ gtk-update-icon-cache -q -f usr/share/icons/hicolor
+ update-desktop-database -q
glib-compile-schemas /usr/share/glib-2.0/schemas/
}
@@ -24,3 +26,10 @@ pre_remove()
done
fi
}
+
+post_remove()
+{
+ gtk-update-icon-cache -q -f usr/share/icons/hicolor
+ update-desktop-database -q
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}