summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2020-08-14 17:46:07 +0200
committerRobert Tari2020-08-14 17:46:07 +0200
commita0e3d2121208852459fdccd0a918f95cc80153ca (patch)
tree12a077dbd8de6195adce5810168c9533e3214e6b
downloadaur-a0e3d2121208852459fdccd0a918f95cc80153ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD37
-rw-r--r--odio.install27
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cd78f9cc514
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = odio-bzr
+ pkgdesc = Audio compression tool for FLAC and Nero AAC
+ pkgver = 20.5.21.244
+ pkgrel = 1
+ url = https://tari.in/www/software/odio-bzr
+ arch = any
+ license = GPL3
+ makedepends = breezy
+ makedepends = python-setuptools
+ makedepends = python-polib
+ depends = gst-python
+ depends = gst-plugins-base
+ depends = gst-libav
+ depends = python-html5lib
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ depends = python-psutil
+ depends = flac
+ depends = cuetools
+ depends = shntool
+ depends = atomicparsley
+ depends = mac
+ depends = lsdvd
+ depends = mplayer
+ depends = odio-edit
+ depends = neroaacenc-bin
+ depends = libodiosacd
+ provides = odio
+ conflicts = odio
+ options = !emptydirs
+ source = bzr+lp:odio
+ md5sums = SKIP
+
+pkgname = odio-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0bdd55db5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Robert Tari <robert at tari dot in>
+
+pkgname="odio-bzr"
+_pkgname="odio"
+pkgver="20.5.21.244"
+pkgrel=1
+pkgdesc="Audio compression tool for FLAC and Nero AAC"
+arch=("any")
+url="https://tari.in/www/software/${pkgname}"
+license=("GPL3")
+depends=("gst-python" "gst-plugins-base" "gst-libav" "python-html5lib" "python-beautifulsoup4" "python-lxml" "python-psutil" "flac" "cuetools" "shntool" "atomicparsley" "mac" "lsdvd" "mplayer" "odio-edit" "neroaacenc-bin" "libodiosacd")
+makedepends=("breezy" "python-setuptools" "python-polib")
+source=("bzr+lp:${_pkgname}")
+md5sums=("SKIP")
+options=("!emptydirs")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver()
+{
+ cd ${srcdir}/${_pkgname}
+ echo "$(cat ${_pkgname}/appdata.py | grep APPVERSION | sed 's| ||g' | sed "s|'||g" | cut -f '2' -d '=').$(bzr revno)"
+}
+
+build()
+{
+ cd ${srcdir}/${_pkgname}
+ python setup.py build
+}
+
+package()
+{
+ cd ${srcdir}/${_pkgname}
+ chmod +x data/usr/bin/odio
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+}
diff --git a/odio.install b/odio.install
new file mode 100644
index 000000000000..7e35cbe648c0
--- /dev/null
+++ b/odio.install
@@ -0,0 +1,27 @@
+post_install()
+{
+
+ if which pycompile >/dev/null 2>&1; then
+ pycompile -p odio
+ fi
+
+ chmod +x /usr/bin/odio
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+pre_remove()
+{
+ if which pyclean >/dev/null 2>&1; then
+ pyclean -p odio
+ else
+ pacman -Qql odio | grep '\.py$' | while read file
+ do
+ rm -f "${file}"[co] >/dev/null
+ done
+ fi
+}