summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Muenz2022-03-21 10:46:20 +0100
committerKai Muenz2022-03-21 10:46:20 +0100
commit4c39a14ef04a7caa5f9387c721729679648683b9 (patch)
tree44c1ef899e1f023e1a49451f408860117c8ca940
parentf0c81de87f579cf7a00b4dd2fd393c3248c4c64d (diff)
downloadaur-4c39a14ef04a7caa5f9387c721729679648683b9.tar.gz
Version bump, updated dependencies
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c21551e5eb15..08f714a03927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Maintainer: Kai Muenz <kai+archlinux@muenz.net>
+
_pkgname=odr-dabmod
pkgname=$_pkgname-git
-pkgver=v2.3.0
+pkgver=2.5.0.r0.g93e5171
pkgrel=1
pkgdesc="Opendigitalradio DAB modulator"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
-url="https://github.com/Opendigitalradio/ODR-DabMod"
+url="https://github.com/Opendigitalradio/$_pkgname"
license=('GPL')
groups=()
-depends=('zeromq' 'boost-libs' 'libuhd')
-makedepends=('boost')
-checkdepends=()
-optdepends=()
+depends=('fftw' 'zeromq' 'boost-libs' 'libuhd' 'limesuite' 'bladerf')
+makedepends=('git' 'boost')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/Opendigitalradio/ODR-DabMod.git")
+source=("$_pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --tags | sed 's|-|.|g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd "$_pkgname"
./bootstrap.sh
- ./configure --prefix=/usr
+}
+
+build() {
+ cd "$_pkgname"
+ ./configure --prefix=/usr --enable-limesdr --enable-bladerf
make
}